[Linux] OpenGl window


some days ago I updated my SDK since then I cant see anything in my OpenGl window. The interesting thing is the SDK is starting without any errors. After opening the terrain editor I have and see all the tools but no visual only a gray background.

Editor output after opening a terrain:

Running on jMonkeyEngine 3.0.0 RC2 Lwjgl context running on thread LWJGL Renderer Thread Adapter: null Driver Version: null Vendor: X.Org OpenGL Version: 3.0 Mesa 9.0 Renderer: Gallium 0.4 on AMD RV620 GLSL Ver: 1.30 Returning hash code of content Returning hash code of content Checking page id 1.559.710.586 vs stored id 1.559.710.586


that was my first step looking there and I tested the option OpenGL1, Heavyweight Canvas and both together. Every time the same result, only a gray OpenGL window. And if I add the option Heavyweight Canvas I get a error like:

java.lang.IllegalStateException: Display not created at org.lwjgl.opengl.Display.processMessages(Display.java:595) at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:181) at com.jme3.system.lwjgl.LwjglCanvas.runLoop(LwjglCanvas.java:229) at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:228) at java.lang.Thread.run(Thread.java:679)
java.lang.IllegalStateException: Keyboard must be created before you can poll the device at org.lwjgl.input.Keyboard.poll(Keyboard.java:378) at com.jme3.input.lwjgl.LwjglKeyInput.update(LwjglKeyInput.java:79) at com.jme3.input.InputManager.update(InputManager.java:870) at com.jme3.app.Application.update(Application.java:604) at com.jme3.gde.core.scene.SceneApplication.update(SceneApplication.java:300) at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:151) at com.jme3.system.lwjgl.LwjglCanvas.runLoop(LwjglCanvas.java:229) at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:228) at java.lang.Thread.run(Thread.java:679)
org.lwjgl.LWJGLException: X Error - disp: 0x7f7d48018420 serial: 44 error: BadValue (integer parameter out of range for operation) request_code: 1 minor_code: 0 at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(LinuxDisplay.java:318) at org.lwjgl.opengl.LinuxDisplay.nCreateWindow(Native Method) at org.lwjgl.opengl.LinuxDisplay.createWindow(LinuxDisplay.java:480) at org.lwjgl.opengl.Display.createWindow(Display.java:303) at org.lwjgl.opengl.Display.create(Display.java:845) at org.lwjgl.opengl.Display.create(Display.java:754) at com.jme3.system.lwjgl.LwjglCanvas.createContext(LwjglCanvas.java:468) at com.jme3.system.lwjgl.LwjglCanvas.restoreCanvas(LwjglCanvas.java:267) at com.jme3.system.lwjgl.LwjglCanvas.runLoop(LwjglCanvas.java:196) at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:228) at java.lang.Thread.run(Thread.java:679)

The strange thing is I haven’t changed the graphics driver and before the update the OpenGL window has worked just fine.

I am running Ubuntu 12.04 in Virtual Box because the Mac version won’t install for me, however I have the same problem. I have 3d enabled in the vm and blender runs fine however I get errors when starting the SDK, “Error opening openGL window! Error: failed to create display” and “Error opening openGL window! Error: java.lang.NullPointerException” and Error opening openGL window! Error: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,IDE Main]" I have also tried using openGL1 and there is no difference. When I try to run BasicGame I get errors as well. I have JDK7 installed from the repo. I also have installed Netbeans 7.2 w/ jdk7 installed on my macOS, Netbeans runs fine but the installer for jmonkey Starts and then instantly closes. I would really like to get jmonkey working again on both platforms or else I will have to learn Unity3d and probably start a new project.

edit: ok my situation is different because I get errors starting the SDK, I will start a new thread for my problem.

lwjgl neither works in a virtual computer nor on a mac with Java7.
The content of this post is meant to be read as a straight information or question without an implicit dismissive stance or interest in having the other party feel offended unless there’s emotes that hint otherwise or there’s an increased use of exclamation marks and all-capital words.

In my case I have ubuntu 12.10 and I don’t use a vm.

Well i use jme3 with ubuntu regualy without problems, make sure you have real grafic drivers isntalled, (as the default one can do opengl but is software rendered)

The situation with the standard drivers has improved already, and will probably continue to improve.
Right now, if a game isn’t too heavy about graphics, the standard drivers can already provide some decent hardware acceleration - no guarantees, unfortunately, and no support for the latest-and-greatest cards, but it IS getting better, and Valve is most likely going to goad/pressure AMD and NVidia into improving their Linux support (because Valve’s console is going to run Linux, and Valve is investing heavily in porting their own games to Linux in preparation for the hardware launch).

So… it’s not yet looking good, but it’s getting better. (It was about time.)


the problem is solved. Today came a Java SDK update, after this update my opengl window is working again.