Live stream tonight - VisualVM and maybe some Lemur text updates

I think I’m going to point VisualVM at my stand-alone server code to see why it’s using a full core’s worth of CPU at idle. I’ve never setup VisualVM on my Mythruna dev box so this will be educational for one of us… or just fun to watch me bumble around.

If that goes quickly then I’ll try to get to refactoring how Lemur instantiates its text component to allow pluggable implementations. (Else that will be next week’s live stream.)

I’ll post back with a link closer to the time… which is the usual 9 PM GMT-4 tonight (Friday).


Starts in a minute. Sorry for the late notice but firefox was dying and it took my 5 minutes to start it again.


Live stream is done… I’ll post back when I’ve added chapters.

I was not able to get to the Lemur stuff but I did spend 10 minutes or so explaining what I will be doing… and that will be the topic of next week’s live stream: Making it easier to add different text implementations to Lemur. (Like TTF, etc.)

Curious why you are not using NanoLoopSleepStrategy? Or does it have the same issue?

In my case, since I have switched to NanoLoopSleepStrategy on my Linux box, it usually takes around 1% of the CPU when the server is idle (with the legacy one it was taking around 30% I think). Have not tried it on a Windows machine though.

I haven’t tried it. The old one is the default and anyway it’s kind of ‘fake’ CPU usage. I will probably try the nano one.

But still, my laptop fan was yelling for real. :wink:

1 Like

True enough. That’s why I will try it…because even my server fans spin up more than I expect.

Anyway, chapters are finally setup on the video for anyone who wants to skip around.

Edit: I tried the nano loop strategy and (at least on Windows), I get consistent underflow warnings from SimEthereal that I’m only achieving 59 FPS on the systems.

I might make it a configurable option in case that’s not a problem on Linux.

I have seen this log a few times running my game server as well on Linux but the message was not consistent.

I think it is already configurable. I submitted the PR back in 2020.


When I set the nano strategy, I was getting the warning once per second about only 59 frames or whatever… so it’s dropping one frame per second. There is a comment in the nano strategy class that says the feature sucks on windows… I concur. :slight_smile:

No, I mean for my stand-alone Mythruna server so that the person running the server can decide which sleep strategy they want to use.

…because in the end, even I will be running my server on Linux.