Lod in jMP from OgreMAX (or adding manual Lod models in jMP)

Heya!

I was wondering if it will be possible in the future to manually add LOD levels for your models in jMP?

By this i mean adding separate 3d-models, one model per lod level, so you can generate a .j3o out of it?

Right now i’m exporting a 3d model as OgreXML from 3dsmax.

When using the OgreMAX Level-of-Detail (LOD) settings on automatic, it exports a single file which contains all lod levels.

[xml] <levelofdetail numlevels=“3” manual=“false” strategy=“Distance”>[/xml]

Below this follow the 2 different LOD-Levels.



Those automatically generated LOD’s import fine into the jMP, but has the large downsize of no control over the generated mesh and especially the UV’s.

When using the “OgreMax Manual LODs”, it exports a separate model for each LOD-level. In the first model file, the other model files are referenced as lod levels.

[xml] <levelofdetail numlevels=“3” manual=“true” strategy=“Distance”>

<lodmanual value=“0” meshname=“Huisje1_minimal.mesh” />

<lodmanual value=“0” meshname=“Huisje1_lowpoly.mesh” />

</levelofdetail>[/xml]

When i try to import this file into the jMP, the Output window prints:

[xml]Unknown tag: lodmanual. Ignoring.[/xml]

Is there any way to get jMP to actually load these LOD-levels (for instance by editing those values?)

Hope anyone can help me! (if it helps i can post the files so one can see for itself!).

Thanks!

All LOD levels are automatically loaded into models if they are available. Theres no way (yet) to edit them though, you can view them by explicitly setting the LOD level of a geometry.

Yeah, i found that out…the problem is i get a separate file for each manually created lod level. All those separate files are referenced in the first file.

This doesn’t get picked up by jMP since it simply ignores them, hence the:

[xml]Unknown tag: lodmanual. Ignoring.[/xml]

on import.

Try importing using the advanced importer, it might be the data isn’t properly referenced in the exported (xml?) files.

The lodmanual is not supported at the moment. If you want LOD you may need to write your own Control that can automatically switch the models based on distance.

Are there any plans for implementing lodmanual?



Having all the LOD-levels in a single model has our preference since we have quite a lot of models, so this is much cleaner.


normen said:
Try importing using the advanced importer, it might be the data isn't properly referenced in the exported (xml?) files.


Can i conclude that trying the advanced importer won't work for adding the different lod-levels? (and if it IS worth a try, where can i find the advanced importer)?