LWJGL crashing on Mac OS 10.7.5

Has anyone else been having LWJGL crash on the new update of 10.7.5?

I have been getting consistent crashes since this update was pushed out.

Process: Pyware 3D [311]

Path: /Applications/Pyware 3D v7/Pyware 3D.app/Contents/MacOS/Pyware 3D

Identifier: java.Pyware 3D

Version: ??? (12.0)

Code Type: X86-64 (Native)

Parent Process: bash [308]

Date/Time: 2012-12-03 16:14:09.245 -0600

OS Version: Mac OS X 10.7.5 (11G63b)

Report Version: 9

Interval Since Last Report: 5434 sec

Crashes Since Last Report: 6

Per-App Interval Since Last Report: 1051 sec

Per-App Crashes Since Last Report: 6

Anonymous UUID: 45C7FBF9-3DBD-409A-8325-604D2F81164D

Crashed Thread: 24 Java: LWJGL Renderer Thread

Exception Type: EXC_CRASH (SIGABRT)

Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:

abort() called

objc[311]: garbage collection is OFF

Application Specific Signatures:

Graphics kernel error: 0x00000005

Has anyone else encountered an issue like this?

Thank you for any information.

Not really, with Java 1.6 it works for me.

It is weird, it works properly on My 10.8 machine, it is just crashing on my 10.7.5 machine.

I will see if I can get one of the samples to break on this machine.

i just installed the SDK and created a new basic game.

When I attempt to run the game I get.


Dec 03, 2012 4:53:40 PM com.jme3.system.JmeDesktopSystem initialize

INFO: Running on jMonkeyEngine 3.0.0 Beta

Dec 03, 2012 4:53:40 PM com.jme3.system.Natives extractNativeLibs

INFO: Extraction Directory: /Users/py/Documents/JME Projects/BasicGame

Dec 03, 2012 4:53:40 PM com.jme3.system.lwjgl.LwjglAbstractDisplay run

INFO: Using LWJGL 2.8.4

Dec 03, 2012 4:53:41 PM com.jme3.system.lwjgl.LwjglDisplay createContext

INFO: Selected display mode: 1280 x 720 x 0 @0Hz

_NSJVMLoadLibrary: NSAddLibrary failed for /libjawt.dylib

JavaVM FATAL: lookup of function JAWT_GetAWT failed. Exit

Java Result: 255

BUILD SUCCESSFUL (total time: 8 seconds)

Any Ideas?

[java]package mygame;

import com.jme3.app.SimpleApplication;

import com.jme3.material.Material;

import com.jme3.math.ColorRGBA;

import com.jme3.math.Vector3f;

import com.jme3.renderer.RenderManager;

import com.jme3.scene.Geometry;

import com.jme3.scene.shape.Box;


  • test
  • @author normenhansen


    public class Main extends SimpleApplication {

    public static void main(String[] args) {

    Main app = new Main();




    public void simpleInitApp() {

    Box b = new Box(Vector3f.ZERO, 1, 1, 1);

    Geometry geom = new Geometry("Box", b);

    Material mat = new Material(assetManager, "Common/MatDefs/Misc/Unshaded.j3md");

    mat.setColor("Color", ColorRGBA.Blue);





    public void simpleUpdate(float tpf) {

    //TODO: add update code



    public void simpleRender(RenderManager rm) {

    //TODO: add render code


normen said:
Not really, with Java 1.6 it works for me.

Are you sure that you are using java 1.6? LWJGL does not work on java7 on OSX.

I had a similar error with Java 1.6 once too… But it vanished quicker than I noticed it…

Oh, then it might not be the java version.

I somehow lost Java1.6 on the mac, can’t run my projects there anymore so I can’t help test this :cry:

oO You just need to make the jdk7 folder at /Library/Java/JavaVirtualMachines/ write-only, then it should fall back to 1.6.

1 Like

So simple, @normen is like the Oracle :slight_smile:

I tried the simple application on my Mac OS X Lion 10.7.5 (11G63) - ran from the SDK RC2 (stable - no nightlies) without problems, blue cube and everything.

Edit: Just updated to nightly (breaks!) and still no problem when running from the SDK.

1 Like

Cool, glad you got it working again. Due to the access rights I found just doing this is easier than moving it. I hope we can get into a hot testing phase for JOGL some time soon, then it will surely help if you have some platforms to test nightly on :smiley: