.material Problem

Hi everyone. I’m having a problem using an ogre .scene file from Blender. I have all of the files (.mesh, .material, .scene), however, when I try converting the .scene to a .j3o, it’s unable to find the material file (but it’s right next to it!!!)

Any ideas? Thanks.


it has to have the same name as the .scene file

Edit: Otherwise, you can configure the material name in the key settings (properties of the file) before converting.

Dang normen, you are fast! Yeah, it does have the same name… I just got the screenshot in there :wink: lol

Just convert the xml, you don’t need the scene file if its only one mesh. The material file doesn’t seem to be made for that scene, probably its the one from the mesh.

A reply to the edit: Nifty, I didn’t see that setting! Unfortunately, I tried setting the name and it still didn’t work… I tried Sinbad.material, Sinbad, .material… What am I missing here?

Edit The material goes with the mesh… But there’s a few things in the .scene… I was going to delete those anyways, but I guess I’ll try deleting those in Blender and then exporting it again…

Yes, exporting the material for a whole scene was tricky sometimes, I can remember…

Sweet, I just deleted the extra things I didn’t need (sword and sheath :P) and exported it as a .mesh and it works now! Although, the .skeleton export is messed up because it only exports one animation -.- blarg. Now what, oh he-that-is-all-knowing? :wink:

Select all animations for export :stuck_out_tongue:

UHHGGGGGG BLENDER 2.59 IS SO MUCH MORE DIFFERENT FROM 2.49b headdesk How am I supposed to select the animations in 2.59 (there doesn’t seem to be the animation selection box like there was in 2.49b -.- ) Sorry for the noobishness :expressionless:

I don’t know but I guess the exporter has a help document like the old one.