In TestClipState, the following line:
clipState.setEnableClipPlane(ClipState.CLIP_PLANE0, true);
clipState.setClipPlaneEquation(0, 0.5f, 0.5f, 0,0);
should more accurately be…
clipState.setEnableClipPlane(ClipState.CLIP_PLANE0, true);
clipState.setClipPlaneEquation(ClipState.CLIP_PLANE0, 0.5f, 0.5f, 0,0);
As the first argument should be a plane index and those are represented by constants?
It is easier to read, and less error prone. But to be completely consistent the rest of the parameters should also reflect what they really are…
clipState.setClipPlaneEquation(ClipState.CLIP_PLANE0, 0.5, 0.5, 0.0, 0.0);
Since we're making it easy ;).
Commited, r4074.