Missing lib files

I realize this is a repeated topic, but i've tried all the solutions listed in the other threads, and i'm stilling getting this error:

arjun@1337:/jme$ sudo java -Djava.library.path=/usr/lib/j2sdk1.5-sun/jre/lib/amd64/ -cp ./lib/lwjgl.jar:./lib/jogg-0.0.5.jar:./lib/jorbis-0.0.12.jar:./target/jme.jar:./target/jme-awt.jar:./target/jme-effects.jar:./target/jme-model.jar:./target/jme-sound.jar:./target/jme-terrain.jar:./target/jmetest.jar:./target/jmetest-data.jar jmetest.effects.TestDynamicSmoker
Mar 23, 2006 8:52:25 PM com.jme.app.BaseGame start
INFO: Application started.
Mar 23, 2006 8:52:25 PM com.jme.system.PropertiesIO <init>
INFO: PropertiesIO created
Mar 23, 2006 8:52:25 PM com.jme.system.PropertiesIO load
WARNING: Could not load properties. Creating a new one.
java.lang.UnsatisfiedLinkError: /usr/lib/j2sdk1.5-sun/jre/lib/amd64/liblwjgl.so: /usr/lib/j2sdk1.5-sun/jre/lib/amd64/liblwjgl.so: cannot open shared object file: No such file or directory
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1668)
        at java.lang.Runtime.loadLibrary0(Runtime.java:822)
        at java.lang.System.loadLibrary(System.java:992)
        at org.lwjgl.Sys.<clinit>(Sys.java:61)
        at org.lwjgl.opengl.Display.<clinit>(Display.java:96)
        at com.jme.system.lwjgl.LWJGLPropertiesDialog.<init>(Unknown Source)
        at com.jme.app.AbstractGame.getAttributes(Unknown Source)
        at com.jme.app.BaseGame.start(Unknown Source)
        at jmetest.effects.TestDynamicSmoker.main(Unknown Source)
Mar 23, 2006 8:52:26 PM com.jme.app.BaseSimpleGame cleanup
INFO: Cleaning up resources.
Mar 23, 2006 8:52:26 PM com.jme.app.BaseGame start
INFO: Application ending.

thanks for any help you guys can provide.

Or install a 32 bit enviroment and SDK.

If the file is in that directory after all (I just looked at the "No such file or directory" part) then, as a general note: if you have a directory "amd64" you generally only want to put files compiled for amd64 in it :wink:

As explained in the various starter guides, the native lwjgl files (.so on linux) should be on the  java.library.path . So I doubt you tried all the solutions :wink:

Also, as far as I know there are only untested 64 bit builds of lwjgl, and none tested with jME. I say that since it looks like you're using a 64 bit VM, which will require a 64 bit version of LWJGL.

Ah, perhaps that's why I'm having trouble getting jME to work on my box as well then. :o

I'm running FC4 64 and am having a similar issue.

Llama, it's not that it doesn't have th java.library.path set correctly as it is displaying the liblwjgl.so file in the UnsatisfiedLinkError and in the correct place I'm betting.  I believe this is entirely to do with the 64 bit issue you mentioned…I hadn't even considered that.  It looks like I'll be spending the weekend trying to get LWJGL to compile on my 64-bit processor. :-p

Or I might just have to switch back to Windows until a solution can be had…


I'm running WinXP 64, but use a 32 bit VM for practically everything (because of the same problem, JNI requires 64 bit libraries which do not exist for things like SWT, LWJGL, etc)

But you're saying you do NOT run a 64 bit VM, but it does have a /lib/amd64, and you did place liblwjgl.so in it? (according to darkfrog)

Well, the exception is similar on mine, except it refers to the explicit location of the liblwjgl.so file in my java.library.path, which if I specify a path where it is not, it throws a different message.  I am running Fedora Core 4 64-bit and running the 64-bit JDK 1.5.  I originally had the 32-bit version of the JDK installed but it was having errors that were caused by running it in a 64-bit OS.  I bet those could have been resolved, I just would rather be running a 64-bit VM if possible.  I think I'm going to have to join the effort to get LWJGL running in 64-bit so I don't have to boot to windows any time I do any game development.


OK… I think I read in their forums once there was some experimental changes to the build file in CVS to support 64 bit (but not tested much). Could have been pre .99 though… good luck :slight_smile:

yea, the file is in the directory… i've checked. I reinstalled my video card drivers, and the scariest thing ever just happened… I crashed linux! I always thought it was impossible, but w/e. I have to do a reinstall over the weekend ne way. So, i booted into windows, and installed jme, and it installed fine. (looks like lwjgl isn't for amd64 after all) the tests all worked (and i gotta say, they look good). but when i try to compile my own stuff, it doesn't work… well, it compiles, but won't run (NoClassDefFoundError) . it can't find com.jme.app.SimpleGame, so its time to start checking classpaths… yay…

EDIT: i'm starting to think it's my java installation (its a fresh one…).

EDIT 2: figured it out… i'm stupid. how the hell could i forget to put the class file directory into the classpath?!

hehe, well, no matter how seasoned a programmer you are it's always the forehead slapping solutions that will kick you butt. :-p

I don't know how many times I've been convinced of some conspiracy at Sun that caused problems with my code when in fact I had missed something so basic I never even thought to go back and check it.  Those are the times that it is well to go back over everything completely simple before saying anything to anyone for fear of showing your own ignorance…it's why I've been posting questions less frequently around here. :wink: