Model wrongly(?) loaded in jME

Hello.

I’ve made a very simple model of soccer goal in 3d max and exported to .3ds, but when I import it into jME it looks strange. There is only one option when exporting, to preserve 3d max textures, but result is same for both cases. Color is different, should be metallic gray instead of black, and one side of goal is missing. Take a look:







What am I doing wrong? When I turn on showing vertices (“n”) goal doesn’t have any vectors. Thank you.

Edit: ok “n” probably stands for normals :slight_smile: … so that explains bad lightning (black color). But why aren’t normals shown?

Kova said:

But why aren't normals shown?


probably because no normals are exported. try exporting to .obj. the obj loader was improved recently and the obj format is very easy to analyze (it's simple text) so you can see if everything is in place (texture paths, vertex normals, etc.)

edit: and make sure you triangulate your models.

thank you … i've played with 3d max a bit and solved the problem. jME is fine :wink: … First of all I can't export to .obj, it isn't supported and there is no plugins for that, only for importing. Second, when i exported to 3ds and imported back, 3d max also displayed model as black. Then I inverted all normals and it worked in jME, even though in 3d max it stayed black.

Stupid 3d modeling programs, I hardly have time to learn programming, now I have to learn modeling also :frowning:



edit: the side of goal that was missing appeared also… don't ask me why or how :slight_smile: