MonkeyWorld Bugs/Errors Thread

i was thinking that Monkeyworld needs a centralized place for any error and bug detection so that any problems can be promptlly dissected and solved. :slight_smile: I will keep a list of all the problems addressed and solved below :slight_smile:

NOTE! When reporting a bug, issue, error include:

a)version of MonkeyWorld you're using

b) any exceptions thrown

c)nature of the issue





Importing a monkeyWorld level into jme

if there is already a post like this, please let me know.

i'd rather suggest you use the sourceforge tracker: also provides forums, mailing lists and recently they even added the option of enabling a wiki for each project.

yeah i'm biased and  a fan of because that's the place i get most of the software i use  XD

lol XD i didn't see that  :smiley: I'll be sure to report any bugs to the sourceforge tracker when i have the chance :slight_smile:

I've used the bug submit under sourceforge, but there has been no reply in nearly a month. So either it's something extremely simple that I'm doing wrong, but it's stopping me from using this great tool.  Much appreciated if someone can help me get Monkeyworld3D running:

When trying to start MonkeyWorld3d (v4), it fails to load. Error message

recorded in log as follows:


!SESSION 2007-06-15 17:18:16.081

java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.update.configurator 2007-06-15 17:18:17.065
!MESSAGE Could not install bundle plugins/MonkeyWorld3D_1.0.0.jar No
Bundle-NativeCode match

!ENTRY org.eclipse.core.runtime 2007-06-15 17:18:17.722
!MESSAGE Product MonkeyWorld3D.product could not be found.

!ENTRY org.eclipse.osgi 4 0 2007-06-15 17:18:17.737
!MESSAGE Application error
java.lang.RuntimeException: No application id has been found.
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(
at org.eclipse.core.launcher.Main.basicRun(
at org.eclipse.core.launcher.Main.main(


I'm on Vista Home Premium and I think Java 1.6.  Surely other people must be having this problem.
It happens as soon as I try to load M3D after downloading a fresh copy.  :?

Many thanks.

Well, i've downoaded monkeyworld 3d 4.0, the problem is that unable to create new project, i mean everythign seems to go well except that id doesn't apper in the navigator! I've tryied bot, linux and windows versions, maybe im doing somethign wrong. Any ideas?

Also,as far as i can see that there is only one one tool to convert monkey3d file to jme format, and it doesn't work with the current version, does it mean thta monkey3d is useless at this point?

Liquidream said:

!ENTRY org.eclipse.update.configurator 2007-06-15 17:18:17.065
!MESSAGE Could not install bundle plugins/MonkeyWorld3D_1.0.0.jar No
Bundle-NativeCode match

This has already been fixed. Windows Vista was missing

Hi guys,

My first post ever. Trying to build MonkeyWorld 3D 4.0 on Windows Vista using Eclipse 3.3 and Java 1.6.

At first I got compilation errors for IDEInternalWorkbenchImages.IMG_LCL_LINKTO_HELP, which I commented out. Then I got the following error:

I followed the build instructions from:


!SESSION 2007-09-06 00:23:54.524

java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_AU
Framework arguments:

MW3D has been split up in several plugins.

But this ClassNotFoundException is strange.

Yeah it's weird, considering I don't get any compilation errors for com.mw3d.swt.ui.Activator and all the libs are added.

I re-checked out the MonkeyWorld3D module out of SVN again. This time I didn't modify anything and tried to follow dougnukem's instructions:

dougnukem said:

To launch the application, I opened up the META-INF/MANIFEST.MF with Eclipse's Plug-in Manifest Editor (should be the default but if not right click and select Open With >> Plug-in Manifest Editor).

In the editor on the right side underneath the Testing header there is a link that says "Launch an Eclipse Application", click that and you're ready to rock!

but instead of getting ready to rock, I'm getting the same error again

This is really strange. I couldnt do anything to reproduce this. So here are some ideas that might help:

  • Have you added all required plugins in the Run configuration (Run/Plug-ins: launch with: plugins selected below, press "Add required plugins")
  • Delete the runtime folder before running, maybe eclipse caches some old packages

Thanks Vardamir, I managed to get it to work. Ended up setting Run/Plug-ins/Launch With to be: "all workspace and enabled target plug-ins".

Hm, very interesting. Good that you got it running. And if you find any bug, dont hesitate to post it here.