MonkeyWorld3D 4.0.2

Hi all,

We are proud to announce the release 4.0.2. This release is way better than the previous release, in many fields, and much easier to use.

Here is the list of changes that we have already introduced in the 4.0.2 release.

  1. Migration to latest jMe release.
  2. Migration to jme physics latest.
  3. Enhanced selection facilities and spatial movements. Both in the single selection and multiple selection, there are now free movement tool plus the gizmos.
  4. Multiple selection in the editor, you can now select more that one object in the editor, and change its transformation attributes, like translation rotation, and scaling, both with gizmos, and free movement tool. Multiple and single selection works from both the 3d scene, and the content outline view. Also the selection gets reflected on both sides, if you try to select from the 3d scene, then it will get reflected on the content outline, and vise versa.
  5. Cloning object via free movement tool by holding the CTRL button.
  6. Cloning of render states via the drag and drop, if you have a spatial with some render state activated on that spatial, then it's just enough to drag and drop that state to a destination spatial, and it will get applied.
  7. Alignments tools in the editor, you can align your spatials in the 3d scene, align bottom, top, left , right, and in the z direction as well. Make the same distance between those spatials as well.
  8. Enhanced code.
  9. Adding of the missing command components, there was some set of missing commands from some of the components in the editor, now they are all in there, so every move in the editor, can be rolled back, and redone as well.
  10. Improved content outline for the missing objects, now almost every thing show in the content outline, like controllers, lights, states, textures, … .
  11. Improved way to delete your items from the editor.
  12. Code refactoring to be easier for other users to extend the functionality of the editor.
  13. Preferences for the camera, and the threshold of the gizmos. Also the introduction of the preferences will help us, and other users to add more features to the editor.
  14. Using game states for our debug shapes and nodes that we add to the editor, for example the surrounding boxes, and gizmos, this idea was suggested from BlackBlueGl. Anything that will not be part of the scene will go those game states.

    The download url is

    Also the source code for this release is branched, and can be downloaded from this url:

    This branch contains the code that we have generated the bin distor from so you must get the same results if you try to build the project.

    Feed back is very welcomed.


And here's the link to the update site:

Momoko_Fan prays that it works on his machine…


Thank you very much for fixing that evil bug!

Oh, we fixed a lot  :smiley:

Good that one of those was your bug  :smiley:


Some of the users on our site, reported a problem while checking out code from the SVN ( may be its the same issue with Momoko_Fan ), he was trying the web url, and not the actual url of the SVN.

Here is the actual download if you want to check it out with SVN client.      For the code of the latest release.      For the latest code.

Will there be a Linux release of 4.0.2?

Wine gives the following exception:

Exception in thread "main" java.lang.NoSuchMethodError: method getPath()Ljava/lang/String; not found
        at org.eclipse.equinox.launcher.Main.computeLogFileLocation(
        at org.eclipse.equinox.launcher.Main.openLogFile(
        at org.eclipse.equinox.launcher.Main.log(, Compiled Code)

That's odd…url.getPath() has been available since 1.3.

Hi Oak,

I really don't know what is causing the problem, but the editor needs java 1.5 to work properly, may be its the reason don't know really. Where did you get this exception, does it appear on the log file, or it didn't even start  ?

You might want to check it out from the SVN if you have time and see what happens with you, it might show more why its doing this.

Still we don't have the linux version. But I believe that duenez would help in it, he is the linux guy.

You can also check it out and follow some of the instructions done by ncomp, see this thread:


Yes, yes, I am sorry about being so quiet lately  ://, but I had some good vacations, those in which you are unable to touch a computer for more than 15 minutes  :wink:

Anyway, I will get back to supporting Linux for MW3D as soon as possible. (Oh, and BTW, it is almost working, so stay tuned!)

Linux version support updated!.. Tested it, and it is as easy as downloading from SVN and running  :wink: Mac support to come, maybe tomorrow.

Thanks you so much for the great effort duenez.

Nice work.

? what became of TGiantLabs

? what became of TGiantLabs

You mean tGiant ? He is currently very busy at work, life is hitting him a lot.

Good news… Mac version is ready to go, so both Linux and Mac should be up and running.  :smiley:

Hi all,

Mac binaries are their for you to download, they were done by duenez , he actually send me both Mac and Linux, I will do linux later. So much thanks to you duenez.

The tar file is  MW3D_4.0.2_Mac.tar.gz

Hope that Mac users will enjoy it :D.

will there be a 64 bit package ? (xubuntu)


i have tried it with windows vista and

i see nothing in the editor field in the center ?

can t add anything ?

possible variations

  1. i am stupid * :frowning:
  2. the tool is a load of crap :-o

    *but i used monkeyworld3d version 2, unrealed, hammer …

    all in all i should know how it works
golden_jubilee said:

i have tried it with windows vista and
i see nothing in the editor field in the center ?
can t add anything ?

Have you opened a file yet?

golden_jubilee said:

possible variations
1. i am stupid * :(

I can't tell :P

golden_jubilee said:

2. the tool is a load of crap :-o


Notice that to add thing to the scene, you need to click on the upper right corner, after selecting the root node… There is an icon that looks like a broken arrow or something… it will display the menu of things to add, like primitives, particles, etc.


We are using MonkeyWorld3D for the first time for a project but none of us can save our scene files at all. When we re-open the scene file, no changes was saved.

(We tried it on three different computers)


i experience the same problem as darkfrog a long time ago: importing collada models does nothing, i can hit the buttons as i want to, but nothing happens.

It's a 4.0.2 version from sourceforge.

Please fix this… :frowning:

thanks, kain