MonkeyWorld3D RCP source code available

Hi all,



We have uploaded the source of the MonkeyWorld3D rcp on the sourceforge SVN. You can get it from here.



https://svn.sourceforge.net/svnroot/monkeyworld3d/trunk/MonkeyWorld3D/



We are using Subclips for our SVN client, but you can use else, but I don't know any right now.



This will only work on eclipse 3.2 and will not build on anything else, due to the fact that its an eclipse rcp application.



Here is the process for checking it out with Subclipse:

1.Open the new wizard, and choose SVN, ( Of course Subclipse only ).

2.Enter the url above.

3.Check the project with the (New Project wizard ).

4.Entry the name of the project  ( Must be MonkeyWorld3D ) or you will have alots of problems.

5.Choose (Plug-in project).

6.In the next page don't choose to create RCP.

7.Don't change anything, cause it will be overridden through the check out.



Continue checking it out, and wait for it to finish.





Now every thing is finished, but you will have alots of compilation errors, ( At least I have faced that ) its due to the unresolved class  path of the libs bundled.



To solve this open the plugin.xml, ( go to runtime tab , to the classpath section ), and remove all the libs from their, ( don't remove the . ), and click on add again, it every thing must work like a charm then.



– Running:

1.Go to Run, and choose to create a new Eclipse Application.

2.call it MonkeyWordl3D  in the program to run choose MonkeyWorld3D.product.

3.In the plug-ins tab check all the dependencies for the product. Run and enjoy.



Please tell us if you face any issues while trying to run it.



Good luck, and wish it will work fine with those whome will try to build it.





PS: The binary version, is very very soon.

whats the reason for "MonkeyWorl3D" instead of "MonkeyWorld3D"?

Ouuuutch, just typo man. Sorry.  OpenOffice completes the words, and I have typed the first word incorrect and choose from the autocomplete. I will edit it. Thats what happens to me while dealing with many things at the same time  XD

hehehe cool :slight_smile: just got curious when it was repeated so many times…hehe

Copy and Paste is NOT your friend. :wink:

Copy and Paste is NOT your friend. Wink  :smiley:

Is that the helmet of mambrino you wear upon your head? :o

Hi all:



Following the first post regarding running the code after downloading it:



    – Running:

          1.Go to Meta-Inf folder and open the MANIFEST.MF file

          2A.In the Overview page tab under the section Execution Environments click on the link  "Update the classpath and the compiler 

            compliance settings"

          2B.As an alternative, you can also go to runtime tab and then to the classpath section, and remove all the libs from there,                       

        (don't remove the .), and click on add again.

          3.Under the Testing area on the Overview tab click on "Launch an eclipse application" link and enjoy.



         

I hope it helps.


hi goodwill_p,



Thanks alot for this, those must go to the user manaual for the spatial editor, hopefully for the next update.



–Outrunner.

is the svn repository of monkeyworld3d still ok???

i've tried downloading via subclipse and the command line and i get a checkout fail…

actually does a mac port of monkeyworld 3d rcp exist???

that would save me recompiling it for mac…

thanks…

got it working by downloading from the command line and creating new plug in project and just hacking away at it…

mac monkeyworld is great  :slight_smile:

The SVN URL didn't work, here is a URL that worked:



https://monkeyworld3d.svn.sourceforge.net/svnroot/monkeyworld3d



If you are trying to run under Windows Vista, you have to change the manifest.mf Bundle-NativeCode:

Bundle-NativeCode: lib/lwjgl.dll;lib/jinput-dx8.dll;lib/jinput-dxplugin.dll;lib/jinput-raw.dll;lib/lwjgl-fmod3.dll;lib/lwjgl.dll;lib/OpenAL32.dll;lib/odejava.dll;osname="WindowsXP";osname="Windows2000";osname="Windows2003";osname="Windows Server 2003";osname="WindowsNT";osname="Windows98";osname="Windows95";osname="WindowsVista"; processor=x86



Notice the osname="WindowsVista"

Thanks alot Vardamir , I totally forgot about it.



Also I have committed the MANIFEST file change.



Thanks alot again.

No problem. I wish i could forget about this Windows Vista crap too