MTGame version of IslandTest (ie: WaterRendering)

First off, I am enjoying MTGame (so far so good), though this water rendering has been "devilish"… I finally found PassTest in MTGame which seems to have the same issue I am having…

Having the water "reflect" the mountain scene! It has the textures moving and there is alpha (ie: one can see into the water), which is neat, but the created reflection does not appear to work, which I would also like to try! Perhaps for more info I would like to see something on the videos pages of with the first video of the island.

Btw, PassTest might want to be renamed to TestIsland to match the JME test, but no biggy. It was very helpful once found for getting water to work.

To be fair I seem to be having trouble with the TestIsland too, but primarily with the Terrain… The water also does not have the desired reflected look.

Is this feature broken in JME?

Just out of curiousity, what is the reason for a "duplicate", reflected Terrain being created? Is it because it is simpler (ie: fewer textures)? It appears this way, but just curious.

Btw, where should i post MTGame questions, here or Not sure whose problem this is (my graphics card, mtgame, or jme).

It's possible the island test was broken in one of the recent changes, but I doubt it  :expressionless: It's also possible its broken in MTGame, but not in jME.

It worked fine before, what video card do you have and did you download the latest drivers?

Well the MTGame version still doesn't work (in fact it looks worse…), can someone else test PassTest from the MTGame community?

The jME version works pretty well now (the water actually looks amazing, the mountain not so much (just white), but that is not as big of a deal (I hope)). Thanks for the advice to upgrade the driver, looks better now.

So I have no clue whats wrong, no errors… just bad graphics:

There is no reflection, attempting to add the skybox to the reflection list removes the actual skybox, attempting to add the mountains reflection removes the water all together!

Running the test "PassTest" seems to garnish similar results! someone willing to help on this?

I'll take a look at it.


Thanks I really appreciate it!

still curious about this… still can't figure it out bump. Maybe its my card, but I got the newest drivers…