Multi-view Problem

Hi,



Trying to have multiple camera views in my simulation and have been directed to look at this:



http://code.google.com/p/jmonkeyengine/source/browse/branches/jme3/src/test/jme3test/renderer/TestMultiViews.java



But when I run this file, only the teapot which is rendered using the original cam object (the bottom right of screen) renders correctly, and the others are a complete mess (unrecognizable images, flashing black and white stripes). I am running the jMonkeyPlatform (latest nightly) on Mac OS 10.6.6.



Any ideas how I can get this code to work? If not, what I’m trying to do is display the camera image from a chaseCamera in a seperate viewPort, which is supposed to simulate the view of a camera attached to a robot’s head, so any work around suggestions would also be great.



Thanks heaps



Adam

What is your graphics card? And since you use the latest nightly, go to Help->Check Graphics Capabilities and post the content here too.

Thanks for lightning fast reply!

I’m using a MacBook Pro which switches between Intel HD Graphics (288MB) and a NVIDIA GeForce GT 330M

w 512MB. The check graphics capabilities function in the help menu seems to crash my jMonkeyPlatform, I’ve tried it several times…

I have the same card/MacBook Pro, didnt have any problems with these tests until now. Do other OpenGL applications work?

I can run the test just fine, it might be your graphics card or memory has a problem…

hey normen, in the day or so since your last post I have upgraded my macbook, now running the AMD Radeon HD 6750M 1GB card. Running the test multiviews code now lets me see the 4 teapots from different angles, however the three clones (i.e all except the original cam object, viewport bottom right) still show some rendering artifacts (large black squares). What resolution is it best to render at? 16,24,32 bpp? And I’m not sure what the 2x,4x,etc… pull down is changing, but what settings have you used to get this code running correctly?



Thanks again

Did you by any chance take over the memory from the old laptop? Normal 24 for windowed or 32 bpp for fullscreen without anti aliasing (thats the multiplier setting) woks fine for me.

i wanted to, but apple changed the RAM spec to 1333 Mhz, so old RAM was incompatible. (So no.)

I’m fixing a bug in my jMonkeyPlatform which discussed on another forum (sceneviewer stuck at 14% loading) and reinstalling, hopefully that will fix the issue.

This is strange, normally it works on all compatible macs or on none… Thats the whole idea about macs ^^

Sigh, no joy. Still rendering weird, get weird flashing black and white where 3 teapots should be… no clue what to do next

I used the same method to clone the original cam object to view another angle of a scene I am making, and it renders kind of properly, but moving objects leave a trail of their past positions in the image, so a moving model leaves a stream of its image.

Here is the output from (now working) check graphics capabilities:



Graphics Capabilities


FrameBuffer
FrameBufferMRT
FrameBufferMultisample
OpenGL20
OpenGL21
ARBprogram
GLSL100
GLSL110
GLSL120
VertexTextureFetch
TextureArray
FloatTexture
FloatColorBuffer
FloatDepthBuffer
PackedFloatTexture
SharedExponentTexture
PackedFloatColorBuffer
TextureCompressionLATC

Sorted! The problem was this line of code:



viewPort.setClearEnabled(true);



That for some reason wasn’t in the version of TestMultiViews.java which I downloaded.



Thanks very much for your time.