MW3D - Vista x64 - Version 4.21 Problem

Hello Guys,

I am new to the Monkey World 3D and I would try this Engine out. But I have no Idea how to run the Application. I've downloaded the Version 4.21 and if I clicked on the Application the Programm says that I need a JDK or JRE in order to run it. I have the newest Versions on my Computer.

I want to use MW3D in Netbeans and so, what should I do?

Greetz from

MC DarkMaster

Are you sure you have a 64bit JRE installed? If all failes, you can try to copy a JRE into the MW3D directory (just like it is possible with Eclipse as well)

MW3D is an Eclipse RCP application, so no NetBeans support.

Thanks a lot. I've installed the jre in the Programs folder not in the Programs (x86) folder and it works. I thought that I have to load the files per SVN and that would be a little Problem for me because I've got a really slow Internetconnection.

Bye Guys

Ok I have another Problem with MW3D.

If I start a new Terrain Creation Wizzard he throw this error:

An error has occurred. See error log for more details.
C:Program Files (x86)mw3dconfigurationorg.eclipse.osgibundles701.cplwjgl.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform

Then I tried to download the newest Version from eclipse but that didn't worked so I've downloaded this
but there is also the same Problem after replacing the lwjgl.dll
So what should I do now? I think the problem is that the lwjgl.dll is not on 64 bit but I have no idea how to convert it.

Those are the dll's that come with monklypse, and those are the libraries bundled with jME. Hm, so i dont have an idea, why there are 32bit dlls. But this location is a cache. Did you install a 32bit version of MW3D some time? Maybe its just a problem with a cached file. Try to delete the configuration area (C:Program Files (x86)mw3dconfigurationorg.eclipse.osgi), maybe this solves your issue.

No I haven't installed an older 32 bit Version of MW3D. This is the first try. And deleting the configuration area doesn't fix the issue. But if I open a file (terrainfile) again he shows this error:

An error has occurred. See error log for more details.
Could not initialize class org.lwjgl.opengl.GLContext


Looks like a bug, can you please report it here:


Oh I haven't got a Google Account. But I don't understand why this is a bug. I thought it is 64 bit compatible and not the 32 bit version.

Obviously it's not. Maybe there's a wrong dll bundled, if that's the case, then it's a bug

Ok if you think there is a wrong dll in the package it would be fine that I knew what dll could be wrong and there I could download it in order to test it.

P.S.: I've tested MW3D on Windows 7 and there are the same errors. (it is also x64)

As a workaround you can use the 32bit version of MW3D, just copy a 32bit JRE into directory mw3d/jre

Ok I've downloaded the 32bit Version of MW3D and took a 32bit JRE in the folder. Now there are no errors but I made a new Terrain and then I can click som buttons but they all have no effect. I see the toolbox on the right and in the middle I see a grey window with nothing in it. Is that okay? I want to create a simple Terrain with grass. What I am doing wrong or could someone give me a very short tutorial there I can see a small landscape?

I guess you have to zoom out a little bit (using the mouse wheel), then you should see clearer :wink:

Select one of the Terrain Tool button (Paint, Deform, etc), then you should be able to do something

Ok ok, I know what you mean. So I've started mw3d again and I don't know why but I've seen a field of black and blue. This was the first time I had seen sth beyond grey^^ Ok then i clicked on deform to raise the terrain a little bit but that hasn't got any effect. So I've tried to press the right mouse button to show in another direction or move the camera with the keyboard and then the black/blue field disappeared and I've seen the stupid grey colour. Perfect. So I've tested MW3D on another PC with 32 bit OS and there it runs normal. A mysterious flickering but it looks ok. So it seems that there is somewhere a bug  :slight_smile:

Well, might be :wink: