My AVD does not support OpenGL?

I had a problem with even starting an android project but I solved it.

I found out it had to do with the jars that I had.

So I deleted almoste everyone except

jMonkeyEngine.jar (found in opt)


And then I run this script:

[java][/java]import android.os.Bundle;


public class AndroidDashActivity extends AndroidHarness{

/** Called when the activity is first created. */


public void onCreate(Bundle savedInstanceState) {






I get the log error:

###ERROR### Unable to get valid OpenGL ES 2.0 config, nether Fastest nor Best found! Bug. Please report this.
Unable to find suitable EGL config
OpenGL ES 2.0 is not supported on this device

The avd is running android 2.2 v8. Should I set some more properties on it or should I add another vital jar to my project?
Because I thought android always supported opengl to some extent..

1 Like

Sorry I accidently posted before finishing writing this.

Anyhow, interessting solution! I can direct connect my phone to my computer and run the program from there… Smart…

I’ll try that :smiley:

xD You can do that with the SDK too :roll:

@Addez said:
I can direct connect my phone to my computer and run the program from there.. Smart..

Actually there is no other way to test... the emulator does not support ogl es 2

Now only ONE problem remains.

After HARD work, installing, reinstalling, plugging usb everywhere and restarting everything and download so much stuff and shouting even more curses, I finaly manage to get it to work on my phone. Pain it the buuttt I tell you!

Anyways, now I can run and I can print/Log a message upon creating the program.

Only one thing remains and that is:

How do I know which jars to add to the build path?

I have

jMonkeyEngine.jar (found in opt)


But I got an error with my simple program, it was something about plain_texture.j3md asset not found.

So I guessing this has to do with the fact that I dont include all nessecary jars.

But I can’t install them all, that would takes an AWFUL amount of memory!

Also, I can’t even continue debuging because Im already out of memory :stuck_out_tongue:

So what jars are mandatory or how do I find out that package is in what jar file?

lol…I really picture you like some Mr furious yelling at its screen…How come everything is so difficult for you?

about the jars…didn’t we go through this already?

Actually when I shout swearwords I usually shout them in a melody, not scream :stuck_out_tongue:

But anyhow, yes, things are always fucked up when I’m using it.

Simple things to install will not work, not be compatible with my computer/hardware and will for sure require 10 times more plug ins than any other person would ever have to use before it can work.

And yes, I’m suppose to take all jars from the lib folder and go project>properties>build something>add external jars> add everyone.

50% of all those jars will crash my program. If I add jinput.jar or jme3.testdata.jar or j-ogg-oggd.jar it will do the following:

print a hell of a long “warning” message. Atleast 10 times in a row.

Then the shit wont work anyways.

So I would need to know what files are essential, so I wont have to add those error jars again…

I read in another thread that you were using an old version of JME…why?

The jars have been split in several smaller jars since then, to allow you to have lighter bundles.

for example you can remove jbullet if you don’t use physics, terrain, if you don’t use terrain, and so on.

I can do so in the current version as well (29-08-2011)

I mainly use it because the new ones are completly messed up. The graphics gets just, extremly weard. The light of an object depends on which angle you look at it etc. It’s just fail. The one I have is quite new but does not include those extreme errors that the new beta ones have.

But if you read the other post, you might have read I’m doing an utterly simple script. I’m not bringing in my game or anything. Just trying to pain a cube on my phone. Still, the plain_texture.j3md is missing for some reason… Not sure how to fix that really…

Seriously guys.

I cant add all the jars from the archive lib folder, it crash my eclipse.

After adding them and and clicking run it will print:

[2012-02-16 23:23:33 - AndroidDash] Dx warning: Ignoring InnerClasses attribute for an anonymous inner class
(com.fluendo.jst.Sink$1) that doesn't come with an
associated EnclosingMethod attribute. This class was probably produced by a
compiler that did not target the modern .class file format. The recommended
solution is to recompile the class from source, using an up-to-date compiler
and without specifying any "-target" type options. The consequence of ignoring
this warning is that reflective operations on this class will incorrectly
indicate that it is *not* an inner class.

Very many times and at the same time take up 50% of my CPU until it finaly reach the breaking point whereas I have to quit eclipse using task manager.
What sort of wicked jar is behind this?


If I set the app = new Hello() BEFORE calling super constructor, then it works!!

I didn’t even know that was possible! XD

You cannot call anything before calling super constructor. Also the class thats failing for you isn’t even in jME3. How do you keep messing up stuff that bad all the time? XD

Ahh yea yours right, onCreate isn’t the constructor :stuck_out_tongue:

Well, anyhow, I’m not sure, I guess I just have it in me to not see the obvious :stuck_out_tongue:

Tell me, which of the four squares is the JDK download? 1, 2, 3 or 4?

1 Like

lol :smiley: