There should really be some strict naming convention within the framework, earlier I was working with BaseGame.settings and BaseGame.display for example.
one has a function isFullScreen() and the other has a function isFullscreen() (note the case difference)
one has a function getBitDepth() and the other has a function getDepth()
etc
This kind of thing really shouldn't happen. I would recommend moving one of them and deprecating the old name, leaving it in as a stub for now…
Submit a patch to the Contribution Depot!
I agree about the naming convention, there's another example; FastMath.LERP and Vector3f.interpolate.
About the 2nd method thing though, bit depth is actually color bit depth (how many bits for color) and depth bits is how many bits for the depth buffer.