Native bullet + joints


I am trying to run my project using native bullet in order to get support for the SixDofSpringJoint. As long as I do not use any joints, things work fine and I can move things around using RigidBodyControls. As soon as I add joints such as a SixDofJoint or a SixDofSpringJoint, however, I get the following error at runtime:


SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,6,main]

java.lang.UnsatisfiedLinkError: com.jme3.bullet.PhysicsSpace.addConstraintC(JJZ)V

at com.jme3.bullet.PhysicsSpace.addConstraintC(Native Method)

at com.jme3.bullet.PhysicsSpace.addJoint(

at com.jme3.bullet.PhysicsSpace.add(


It seems some people have managed to solve the issue (

I have tried the following nightly builds: 2012-02-15, 2012-06-09 and 2012-07-11

They all produced the same results.

I have also checked out the googlecode svn repository and built the natives using “ant build-bullet-natives” and “ant jar” (for both the latest revision(r.9558) and the one suggested in the thread mentioned before (r.9540)). Again, the results did not improve.

My build path includes all .jar files from the lib directory (except jME3-jbullet.jar) plus the jME3-bullet.jar from the opt/native-bullet directory with the opt/native-bullet/lib directory set as native lib dir.

Not sure if this is important, but my OS is win7 x64.

Please let me know if you have any leads as to what I might be doing wrong or what to try next.



delete the old dll files

btw native bullet has a few other nasty surprises, its not production ready yet

Do you mean the dlls that are created in my project directory when the application is launched (bulletjme64.dll, lwjgl64.dll and OpenAL64.dll)? If I delete them, the error remains the same (for all nightlys and the current checkout).

I could not find any other dlls that I might be able to delete either.

Not sure, if this may be a problem or if its just normal debugging information, but I spotted this during recompilation of the bullet natives? :





[exec] glu32opengl32

[exec] GLUT NOT FOUND not found, trying to use MINGW glut32


[exec] – WARNING: you are using the obsolete ‘GLU’ package, please use ‘OpenGL’ instead

[exec] – Could NOT find GLUT (missing: GLUT_glut_LIBRARY GLUT_INCLUDE_DIR)

[exec] – Configuring done

[exec] – Generating done


Step 1) Download latest nightly

Step 2) Unzip latest nightly

Step 3) Delete jME3-jbullet.jar from /lib

Step 4) Copy jME3-bullet.jar and jME3-bullet-natives.jar from opt/native-bullet/ to lib/

Step 5) Run jMonkeyEngine3.jar

Step 6) See that the joints work fine

Unfortunately, still no luck. Even the sample test TestPhysicsHingeJoint (same for TestPhysicsReadWrite) crash with the same error. Other tests such as TestSimplePhysics work fine. Not sure what could go wrong with a step by step description such as the one you have provided…

BTW: I noticed that running jMonkeyEngine3.jar produces 32 rather than 64 bit libraries.

@poel said:
BTW: I noticed that running jMonkeyEngine3.jar produces 32 rather than 64 bit libraries.

This depends on what java jvm version (32/64bit) you run