Netbeans errors(setiing up the framwork)

I followed the  netbeans 6.7  jme 2.0 tuturial exactly (took me a few atempts :D) but when i tried to run

the helloworld test i get theese errors

[sub]java.lang.NoClassDefFoundError: C:UsersChrisDocumentsNetBeansProjectsJME2JME2jME_2/0_Complete_(r4093)_2libnatives
Caused by: java.lang.ClassNotFoundException: C:UsersChrisDocumentsNetBeansProjectsJME2JME2jME_2.0_Complete_(r4093)_2libnatives
        at Method)
        at java.lang.ClassLoader.loadClass(
        at sun.misc.Launcher$AppClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClassInternal(
Could not find the main class: C:UsersChrisDocumentsNetBeansProjectsJME2JME2jME_2.0_Complete_(r4093)_2libnatives.  Program will exit.
Exception in thread "main" Java Result: 1[/sub]

i was wonderign do you know which part i messed up are correctionts that need to be made

extra info
The engine the 20mg download is stored in    .../netbeansprojects/jme2/jme2/_____

it would be very apreciated if someone could help me out i would lke to start learning JME quicky ive seen so many clips on youtube and it looks amazing.

I know your feeling, I have been building a couple of projects now that I am doing JME etc… sometimes just makes you wish there were monthly releases of the jars lol. But it becomes easier each time.

To be honest I used Eclipse, though in Netbeans I did build a Jme (wonderland version)… I opened my netbeans 6.5.1 - my guess from the get go, is you have an issue with your "lib/native" library, which is supposed to hold the "dll" (if windows) for your 3d lgwl libraries.

1). Make sure that the project properties, go to run, and set vm options:

-Djava.library.path="…/JME2/jME_2.0_Complete_(r4093)/lib/natives/"  (ie: wherever your jme2 download is, double check in exlporer that the path exists!).  Of course this error I might expect: "Exception in thread "main" java.lang.UnsatisfiedLinkError: no ___ in java.library.path"

2). Make sure the "main class" does indeed exist? The first line doesn't seem to be a class in itself… It is a directory, and not a class?

The error does seem odd, try running through the Wiki again and see if you can get it going? This time if you are unsure of an instruction try a few things and post here I guess.

Btw if you just want to use JME and not get the code itself, I think you actually can get a jar from googlecode. and in fact you can get the jars themselves and not need to worry too much about compiling the code (which I assume is your problem from the above).

thanks msj yer i started some tuturials and their the errors when i try run it. So i can develop test and build just from the jars? im a big newbie when it comes to this. Ive never extended my java liabries or whatever. ALso if i downloaded the jars how would i intergrate them with the IDE

You can actually find lots of information, infact a wiki for this and JME…

But if you did want to do this, you just download the jars, add them to the netbeans libraries. You do this by right clicking on the java libraries adding it, and browsing for the location of the jars…

To use them, write your own java program and use the "import" statement to import classes…

Are you brand new to Java in general?

Ok thanks  ive written a few programmes in java all functional but none that i or i guess others would pay for lol.

but yer i wouldnt say yer im an experienced java programmer. Dont worry im going to take it slow im not goning to rush into maour ground breakign 3d games. but im a huge gamer and  beign researching game development alot.  I recon by following the tuturials on the site then  starting to self learn  more experienced java and JME at the same time. Yer i floowed the tuturial on how to import them and set it up it should of all worked. WHat i tghe import statement ill look to see if its included into the test application the tuturial said to do i cant remember seeing it.

actually jump right in, have fun with java and jme…

it will be more difficult but the product will be 3D ;)…

If you have the jars, then there are many examples you can simply run, remember in the properties go to run, and set vm options with the correct native library (see the wiki and search for -djava.library.path="…" )

thanks yer i frogot this bit before my natives


thanks for your help

oh okay, happy you got it working.