When I go to your site with Netscape 7.0 all I see is gibberish.

For example the home page starts with:

Tèÿÿoñÿÿ‰úÿÿ•þÿÿ|õÿÿ[êÿÿ"¤Ìÿ!Keô#±g 0

wow… hehe ok, I’ll see if I can figure that out. My web skills are pretty poor and the site is just generated via a web log. In fact, I think it’s pure basic html, not sure why it wouldn’t work.

This is happening because your enconding settings are wrong. In IE, you simply right click, choose enconding->More->English and that would sort it out.

Do you have another language? because I speak arabic, and I have to do encoding->More->Arabic so that it shows up as arabic and not gibberish

Yeah, must be your locale settings. I’ve just gone in via Netscape 7.0 and the site comes up fine. I think though that we could add a meta tag to the pages that would help your browser fix the settings automagically.

:? It fixed its self. :?