New node debugging error


I’ve just started with jMonkeyEngine a few days ago. Right now I’m trying to understand how nodes work in jME following a few tutorials, but for some reason my code doesn’t work when I create a new node.

When I add these two lines at the end of my simpleInitApp() method, it gives me an error:

Node pivot = new Node("pivot");

Also I have tried:

pivot = new Node("pivot");


Node pivot = new Node("pivot node");

I’m running jME on a Debian Wheezy.

Does anybody know what am I doing wrong?


What error? The first line is fine, must be something else, maybe you forgot the import?

1 Like

Aha, I’ve solved it. Yes, I did not notice that the import com.jme3.scene.Node was missing… my falut.

Thanks Normen!

You can right-click the file to add the import or press Ctrl-Shift-I (I think, on windows) to add all missing imports. I’d generally suggest looking into learning a bit more about Java before you go on though, game development isn’t exactly the best way to start learning a new language.