New OpenGL panel in SDK fixing many issues – please test


we now resorted to lightweight AWT panels for the SDK as the lwjgl heavyweight opengl canvas implementation still has some issues. These issues were causing freezes, funny incompatibilities (e.g. compitz on linux) and making the SDK generally sluggish when the opengl window was opened. All of these issues should be resolved now and the panel should be a much more friendly swing citizen overall :slight_smile:

I am right now running a build, please update your SDK’s and test this new way of doing things on all systems, especially things like editing post-pro effects and using the move etc. widgets, I had some issues with these still. (@Momoko_Fan)

Known Issues:

  • mouse y axis inverted
  • problems when resizing with post effects enabled
  • gui node not visible




    Added an options panel to the SDK that allows switching between the new and the old OpenGL window versions. Also allows running the SDK on OpenGL1 devices now.


Already found one issue, the awt mouse input is inverted on the y-axis…

I can only display the openGl window once. Once i change editor, or close the window i cannot open a new one.

No error, and nothing unusual in the log.

I am running jMP under Windows 7 64bit on a geforce 580

add: terrain editor freezes the whole jMP instantly

Hm, ok. I can open the window more than once but I also get just a grey window sometimes, after that it never comes back. The terrain editor freeze I can’t reproduce, I switched between TerrainEditor and SceneComposer and opened both in succession and it worked fine.

Terrain editor works for me only when i have no terrain attached. As soon i attach a terrain spatial and try to switch to the terrain editor the app freezes. Additionally when i try to zoom out by scrolling i need to scroll fast, if i scroll slowly i zoom in instead of out.

I tried it with a scene incl. terrain. Anyway the input of the new jme3 swing panel seems to be borked still, guess @Momoko_Fan will have to look into this.

After a few retys the terrain editor and even the openGL window are now working again. Did nothing new, only restarded the app a few times.

So for me only the scrolling issue left.

I loaded a scene (just a terrain with an other added scene) and tried to zoom.

With this pc I had always the problem that I must press the middle-mouse-button when I want to scroll in with the mouse wheel. Strange, but I was used to :wink:

Now it didn’t worked to zoom in even with the pressed middle-mouse-button. It just zoomed me out more and more.

After closing and reopening the OpenGL window I get now a “Error in scene (java.lang.IllegalStateException: Why did you change the output framebuffer?)” warning and I can not open the scene anymore. Even with restarting the whole jMP.

Something like this happened to me before, but I can’t remember if it was the same warning…

EDIT: Hmm… I can’t edit my posts here, but I can delete them…
Solved ^^

The warning pops up now everytime I want to open something in the OpenGL-window. Not only with the scene that I edited.

Join the group to edit posts

When I open the jMP now with the displayed OpenGL window I get now a null pointer exception (Error in scene).

EDIT: I tried to close and open the jMP a few times and now works the OpenGL Window. At least I can view scenes and models until I edit them (or just change the viewpoint of the OpenGL Window.) If I do that, then I get a null pointer exception (Error opening OpenGL window!) when I restart the whole jMP.

EDIT2: As long as I close the OpenGL window when I close the whole jMP is everything fine (apart from the zoom problem). But when I close the jMP while the OpenGL window is still open, then I get the null pointer exceptions at the next start of the jMP.

…that indeed sounds strange… thanks for the input.

Problems: the zooming in function seems a bit messed up (once you zoom out it zooms in a bit). Also, the only times that I can change the camera (between Persp. and Ortho.) is when I’m in one of the predefined camera views (Right, Front, Left, etc.)

Also, PLEASE fix the invertedness in the Terrain Editor… lol :wink: it’s quite a pain…

Other than that, it looks fine!


I have also some problems with zooming in and out, I have to zoom out quite a lot, otherwise I can get a result being closer while trying to zoom out.

Mouse is also inverted in the terrain editor.

One issue I had with a mesh displayed seems to be solved. Switching between the node and the geom made the mesh disappear at some point so I had to reload the scene.

I edited a material parameters while having a mesh open and this went without any problems. I had no problems with the sceneviewer as described by hamsterpower.

Blender model preview crashed JME (on Ubuntu 11.04 with NVIDIA). Now the IDE crashes instantly. IDE seemed to work fine before plugins were installed. (this was a completely new installation)

Just now a new build has finished that fixes some of the issues, please test :slight_smile:


Scroll issue in terrain editor is still there.

When i run an application from within hte jMP all looks good, but when i exit the application i get a windows warning that Java Platform SE binary has stopped working with following details:


Problem Event Name: BEX64

Application Name: java.exe

Application Version:

Application Timestamp: 4e084cc8

Fault Module Name: OpenAL64.dll_unloaded

Fault Module Version:

Fault Module Timestamp: 4e894561

Exception Offset: 0000000008655dff

Exception Code: c0000005

Exception Data: 0000000000000008

OS Version: 6.1.7600.

Locale ID: 1033

Additional Information 1: b4ee

Additional Information 2: b4ee5de6a2322745523997a782b35692

Additional Information 3: ac83

Additional Information 4: ac83dbcc8fb0606fd9de15f0edb59a69


After launchin an application i cannot use the jMP OpenGL window anymore, jMP throws:

Error in scene!

java.lang.IllegalStateException: Framebuffer doesn’t have any renderbuffers attached.)

Beside that, mause y axis problem is fixed and no other issues found yet. Good work

I get the same problems that zzuegg gets.

And the old bugs are still existing (closing and reopening the jMP helps now sometimes, and I don’t get a warning every time I try to open a scene/model when the OpenGL window is crashed, it just don’t displays anything in the window (buttons, labels… are all working)).

Alright, seems @Momoko_Fan has to look into this again.

@all please don’t be too sluggish with your wording, “crashing” would mean the application quits with an error, “freezing” is when it just stops responding and the others are “errors” or “exceptions” when you do something. Makes it easier to tell whats happening from our side :slight_smile: You also normally get a small red warning sign in the lower right of the SDK, click it to see a stack trace of the error, it might be helpful too.

After launchin an application i cannot use the jMP OpenGL window anymore, jMP throws:
Error in scene!
java.lang.IllegalStateException: Framebuffer doesn’t have any renderbuffers attached.)

After launching application, you mean running the project in jMP, right?