New test build 20110224 posted

This was posted last night but the site was down.

Engine Test Build

There are two fixes in here that will hopefully sort things out for Mac users. First, I fixed my bump mapped materials

so that hopefully those will actually show up as something other than flat shaded.

Two, I made some more water fixes that will hopefully let them show up on Macs. After I made the ATI-related fixes

(that worked) I noticed that water stopped working on my laptop. So I went in for another round of fixes and now it

works on my laptop. And my changes shouldn’t (fingers crossed) break ATI cars. And I’m hoping they do fix things

for Macs, too… since the issue I saw was identical.

Note: this release also saves the world as you go. It makes everything load faster as you are moving around and doesn’t take

up that much disk space. It does mean that the “infinite world” is now limited to the size of your hard drive. :wink:

Anyway, for fun, you can also download the world I’ve been working on:

My Worlds

…you can always just delete the mythra.db if you decide you want to go back to the purely generated world.

Here’s a video of me running around through the world: Mythruna Test Run

It’s not great and it’s supposed to be annotated but it shows of the engine ok.

Yeah, I have bumpmapped surfaces now o/

Water bug is still there though, funnily some water quads appear when I place a glass cube close to the water oO

Well, now I’m at a complele loss as to the water issue. It sounds like it is no longer the same issue though since in the “bad case” water was being drawn but in really bizarre places. So glass blocks wouldn’t have necessarily made it suddenly show up.

I can literally walk across the water and make it visible by placing glass cubes across the ocean xD

And just to confirm (though I think I will get no joy from this), there are two types of water blocks you can place: regular water and water top. I’m assuming if you drop one of each on the ground that neither show up?

Nope, but as soon as I place a glass cube beside they pop up.

Like, you can only see them through the glass cube or just having a glass cube near them makes them show up from all directions?

This is so bizarre.

second, like I said i’d just need to scatter glass boxes around the map to see the water normally

But that implies that it’s related to the transparent bucket and interactions therein. Hmm… and they don’t just suddenly and randomly appear from certain angles like before? That’s new information and potentially a different problem altogether.

I wasn’t sure if you meant scatter or refloor before. :slight_smile: Though a glass floored world would be pretty cool. heheh.

I think this may be the only material in my world without a normal map… and I think I saw some weird state leakage when I had a solid material like that. I ended up just giving it a flat normal map. Maybe I’ll try that for the water to see if it fixes it.

So, I was incorrect: water, leaves (in the trees), and glass are the only materials in my world without normal maps… and coincidentally, are the only transparent textures.

Wonder if placing a block of leaves near water would have the same effect as the glass blocks.

Hey cool,

I finally see some water with the glass trick. And no, putting leaves next to the water does not produce the same effect. The water only appears only with a glass cube in the vicinity.

Interestingly, the water gets drawn with the cube in a specific area. Look what I mean:

Like the water gets ignored without a proper glass cube in its 32x32 block?!

And praise the Macs for their strict interpretation of shader code for it helps you in writing a thoroughly correct program :stuck_out_tongue:

…but it looks like from these pics that it still isn’t animated.

“Stricter than necessary” in this case, me thinks. The code is super straight forward now.

It isn’t animated, no.

And placing a leaf block right where you’ve placed the glass wouldn’t cause the water to show up? (<- that right there is baffling.)

No, as you can see there is leaf block immediately on the left of the water. I could’ve positioned the glass block at the leaf position or even multiple blocks away. I guess it just have to sit in this 32x32 grid thingy to get the water appearing?!?

Ok. Just making sure it wasn’t a issue of being in a different position. That tells me something.

For a 32x32x32 ‘leaf’ (that’s the OctLeaf reference in the HUD), all geometry is batched by material. The thing that the glass block and the water have in common is that they are in the transparent bucket. Leaves are also in the transparent bucket.

…however, since the order they are created is based on a hash, it’s possible that the leaves material is drawn before the water but the glass after or vice versa. Because if it were water, leaves, glass or glass, leaves, water then I’d expect leaves and glass to be interchangeable for fixing the issue. I’m going to look into what order they end up getting created to see if that leaves any clues.

The non-animation may actually be a completely separate issue in this case. I may put together a “just for Macs” test where I remove the animation altogether to see if the disappearing still shows up. Stay tuned.

Ok, I’ve posted a version where I’ve stubbed out the water material and use the same shaders as everywhere else… the water will not be animated but if it still doesn’t appear that tells me something:

No water animation Mac test build.

Wuhuu, water on the mac, albeit standing still.

And because I want 100% to avoid wild good chases, confirming that there are no glass blocks anywhere in the vicinity. :wink:

Ok, so it’s definitely my shader… and my shader plays nicer if glass blocks are rendered first. (They are, I checked… well they enter the render queue first at least.)

Do you mind trying another test build if I post it? I’ll try running through the same process I used to narrow in on the fix for my nVidia card.

Get on with it, I’m all yours :smiley: