New update broke jME

Got the latest update but imports now stopped working.

When launching jME I get:

Project Templates - The module named com.jme3.gde.project.baselibs/1 was needed but not found.

If I disable it all imports in classes are unreferenced.

Uh… dont know what could have gone wrong there, delete your settings in “-user home-/.jmonkeyplatform” and try updating again.



All I have in .jmonkeyplatform is lwjgl64.dll and OpenAL64.dll

Nothing else. No config, no settings.

Then there is another .jmonkeyplatform folder on your system. Inside should be a “dev” folder, delete that one. Theres a list of possible config directories here.

Still the same.

It seems the “jme3” library has disappeared though… I see the others, jme3-libraries, -libraries-gui, -joal, etc, but not the jme3 by itself.

Yes, its because that plugin is disabled. jMP should use the plugins that came with alpha-2 when you delete the settings folder, so it should work normally after deleting it. If thats no the case, delete jMP with the uninstaller.exe (make sure you have the “delete settings” checkbox enabled) and then re-install it.



1 Like

Uninstalling seems to have done the trick.

I kept a backup of the dev folder and if I swap it back the same error pops up. Makes me wonder why the problem didn’t go away when I renamed the folder. :confused:

If you want I can zip and send you the whole dev folder for you to check. It’s 18MB compressed with rar. Let me know if you want it or not.

Thanks too btw. :slight_smile:

Thanks, I dont think it will make me much wiser…

Good to hear it works again for you!

Ok, this isn’t funny anymore.

The exact same thing just happened after last update. I have nothing out of the ordinary in my projects so I don’t understand what the problem is, but it’s damn annoying.

Dont know whats wrong there. Are your harddisks user rights ok? Any way to check that on windows?

If the problem were user rights, every update would fail. I would also have problems with other software or whatnot. Why is Project Template the only update failing?

jMP is installed on D: drive; in Utils directory. That drive doesn’t have anything except development stuff.

Reinstalling did the trick, updates worked without a problem, but this is not the best way… There has to be something wrong, somewhere.

Yeah, windows sucks :confused:

Gah. Another update to Project Templates…

Hopefully, if I’m lucky, everything will be smooth.

Ha! Yeah. I wish.

I’ll be damned!

Worked on first try. No whining, no uninstall/reinstall. Yay normen! :wink:

That crap started again.

“jme3-libraries” library has missing items.

Again it happened with latest two updated Project Templates.

Going into Library Manager and editing the jme3-libraries and adding the necessary files (that were already there, with the same path, etc) worked.

Something wrong is going on during the update I think.

Bwahahahahaha… You’re the only one getting this :stuck_out_tongue:

I know. Maybe it’s because I don’t use the default installation path.

Then there also the fact that for a couple of updates everything went fine, no error… It’s just incomprehensible.

Now back to “jme3” to be not found.