Newb question getting jME compiling

Wow, this post just kept growing and growing as I trying to get this running.

From the top: -

  1. Installed jMonkeyPlatform Alpha-4
  2. File / Open Project:

  3. 71 compiling errors

    a. did a Clean & Build (same errors)

    b. ran an update (2 downloads), reset, C&B same errors

    c. ran another update (14 downloads - 30 minutes later), reset x2, C&B same errors

    d. did another update (2 downloads), reset, same errors

    The error log is here as I didn’t want to flood this post with it.

    Subsequently my screen looks like this

    As the screenie suggests, I cannot run any tests, not even a HelloWorld.

    Other things I’ve attempted: -

    Loading the source in Eclipse Helios SR2 - gets me completely different errors (although errors nevertheless).

    Example: attempts to load missing classes: -

    import org.novyon.noise.ShaderUtils;

    import org.novyon.noise.basis.FilteredBasis;

    import org.novyon.noise.filter.IterativeFilter;

    import org.novyon.noise.filter.OptimizedErode;

    import org.novyon.noise.filter.PerturbFilter;

    import org.novyon.noise.filter.SmoothFilter;

    import org.novyon.noise.fractal.FractalSum;

    import org.novyon.noise.modulator.NoiseModulator;

    I cannot find these anywhere, but admittedly I didn’t look too hard as what I would find may well be the wrong version, and I feel they should be with or referred to from the jME source and thus not my job to find them (also I got the feeling from my looking that they are proprietary code: -


    So, it was after this I decided to download and use the jMP thus leading to all the info above. This is not a casual post, I have now spent a couple of weeks on this. I have even repeated the above process twice as I completely uninstalled jMP and started again (thinking perhaps I had accidently downloaded the overnight build that understandably could be buggy).

    Despite not being able to compile the tests I assumed I could continue with the library. So, I followed the steps here to make a simple android app.

    Problem: “Add jme3/dist/opt/android/jMonkeyEngine3.jar to your library path”

    I could not find where in my new android project where I can add/edit the library path, and I did look. In the end I made a Lib folder and manually copied in jMonkeyEngine3.jar from the “C:/Program Files/jmonkeyplatform/jmonkeyplatform/libs/” folder - but it didn’t include the “” class (neither did the “C:/Program Files/jmonkeyplatform/jmonkeyplatform/modules/ext/” one). Along with this I do not have a /dist/ folder anywhere. (I attempted the Ant build in Eclipse and got the error “Specified buildfile does not contain a javac task”.)

    To sum up, can people help me with: -
  4. Compiling the jME test code (Eclipse and jMP)
  5. Making the .jar libraries
  6. Add/Edit library paths in jMP android projects
  7. Thus, a working hello world android app

    And any other questions inferred here!

    Extra bonus naive question: -

    Will the jMP “Help / Check for Updates” download the latest stable jMonkeyEngine when it’s released?

    (I’m very sorry if these issues have already been resolved elsewhere on the forums, I couldn’t find it.)

    jMP error screenie:

    jMP error log:

    Eclipse error screenie:

To eclipse since many of the jme contributors use netbeans (shudder) the eclipse classpath is often out of date. Just add the noise.jar somewhere in the lib folder of the jme to the buildpath in eclipse. It should compile then. (Else return this step for any other jar not in the buildpath that seems relevant)

Seems like you made it extraordinarily complicated for yourself because you tried to “fix” the tests. It would have worked with a normal alpha-4 install or also the update, you could have just ignored the errors in the tests and run those without errors…

I started simple >.<

But yea, I think it’s my bad - well, I used RapidSVN to checkout the source, I think it’s either missed some files, or got too many. I started completely from scratch within a Virtual Machine, and I think I got it now … but I can see me coming back here :stuck_out_tongue:

Thanks for your quick responses guys :slight_smile: