Newbie question

I am using JMonkey platform alpha 2.

I have installed the samples so I have JME Examples project.

As an eclipse user I am baffled by a few things.

  1. When I modify the sample code it seems to have no effect when I run it. It will tell me if it does not compile, but no modifications are visible.

    Like on Hello application I change a color or even comment out the initialization and it still seems to draw from the original source not the

    modified source.

  2. When I run debug, I get stuck because the application appears and blocks the whole ide screen. If I put a breakpoint, its locked because it

    wont process the escape key.

    I am thinking about switching to eclipse … but I would like to know what is wrong with my environment or the way I am debugging.


Sounds like the tests you are running are executing the jar file and not running off of the source code. Make sure that in Run Configurations, under the test you are running, the classpath tab has the jme3 project listed under the user entries. Also make sure it is the actual source code of the test case you are running, and not the compiled test in the jar file.

Whenever a program is running and it does not reflect the code, it means it is running in a different location. You have to Refresh in eclipse a lot, and sometimes execute Project->clean

I am interested in Eclipse IDE too as developing tool . Please give me a link for this



@devdroider please download Alpha 3 many issues have been fixed since the alpha2.

what OS do you use? whith windows you can use alt+tab to switch back to the IDE when debuging.

@aurelsandu every thing is explained in the documentation if you want to use JME3 with Eclipse