Nifty crashes after reinstall of jmonkeyplatform

this is very odd…

i had to reinstall jmonkeyplattform and opened my old project afterwards.

everything ran fine before, but now i get this error, when i start moving the cursor:

06.06.2011 21:41:12 handleError

SCHWERWIEGEND: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]

java.lang.NoSuchMethodError: de.lessvoid.nifty.NiftyInputConsumer.processMouseEvent(Lde/lessvoid/nifty/input/mouse/MouseInputEvent;)Z

at com.jme3.niftygui.InputSystemJme.onMouseMotionEventQueued(

at com.jme3.niftygui.InputSystemJme.forwardEvents(

at de.lessvoid.nifty.Nifty.update(

at com.jme3.niftygui.InputSystemJme.endInput(

at com.jme3.input.InputManager.processQueue(

at com.jme3.input.InputManager.update(



at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(

at com.jme3.system.lwjgl.LwjglDisplay.runLoop(



Java Result: -1073741819

I guess you had your old version updated to latest nightly and now you have not?

the platform is up to date and i placed the newest nifty builds manually,

like i did before.

what i noticed, is that the old jMonkeyEngine3.jar from my previous installation is far smaller than the updated one now, what makes sence.

but still, even when i do a clean install of the platform and only update nifty, it doesnt work.

does not work:

old nifty and old jme

old nifty and updated jme

updated nifty and old jme

updated nifty and updated jme

with old, i mean the stuff that comes with the alpha4 installer.

i think i somehow managed to update the platform partly in the previous installation and used new nifty bullds and that worked out of pure luck,

what bothers me the most is, that my whole project ran great, until i had to reinstall jme3.

after that, nifty doesnt work and when i disable it, i get blackscreens all the time when using filters like depth of field, or bloom, which worked before.

what now?

I dont know, check if the errors are valid compared to the current api and then fix either the code or the libraries?

I had the same issue. In my case the reason was a broken eclipse-project. I had to reconfigure the build path with all depending libraries. After that it worked again.