Nifty GUI bug when trying to open 'Visual' after editing 'XML'

Hello everyone! I’m working with a Nifty xml file, and the following problem arises:

When working in the ‘Visual’ part of the Nifty menus, I added a GImage, and applied the file-name by clicking on the ‘…’ at filename in the properties. I applied the width, length, etc. and everything worked fine (xml-code was being updated and all that). However, when I try to run the program, it throws an AssetNotFoundException (which is weird, since I selected it using JME3 itself).

Then I tried to edit the XML-file, where it doesn’t call the file from C:/, but only uses Interface/title.png. Now running the file goes fine, and the .png shows up as expected, but now I get a weird bug where I can’t see anything when clicking on “Visual”. JME3 doesn’t switch to the Visual screen, and only if I hover over it with my mouse, the different tabs like the palette and properties will pop up.

Since I’m new with writing XML, it’s very useful for me to use the visual tab to see if what I’m doing actually works.

Am I the only one with this bug or is there a fix for this? I have a feeling it only bugs out when using an image.

Thanks in advance!

EDIT: It started after I edited the filename in XML, but I’ve deleted the entire image from the XML file and it still bugs out…

1 Like

Perhaps you do not have a path for the resource folder in the program.

AssetManager.registerLocator (the “assets”, FileLocator.class);


You first put the file in the game folder, and then select from the SDK. This should solve the conflict.

This may be due to:

1 Like