Nifty Gui ERROR : Black Screen & Cursor displayed randomly!

So i tried to use my own gui system, but visibly your game engine hates him : nothing appeared to the screen all were black. So i decided to use the nifty system because you’re providing an easy implementation of it into your engine.

The problem is that there’s exactly the same problem as with my own gui system :

  • The screen is still black, the Play button does not display same as the game console witch will be used for Addons.
  • The mouse is sometimes ungrabbed sometimes grabbed.

Only way i found to solve the display problem is to use GL11 directly. And for the mouse cursor problem only way i found is to call in loop the Mouse.setGrabbed(false) !

Is that normal that i need to pass directly by OpenGL instead of using your engine ?

Solved display problem. Now the Nifty Gui is displaying. Only problem is that the mainLayer of the startScreen won’t be centered in the screen ! So i have the whole start screen at coords 0, 0, 0 ! I need it in the center of the screen !

But the mous is still randomly grabbed… I so need to call in loop Mouse.setGrabbed(false) !

So the nifty gui is working ! I’ve made a bind to bind my own gui system to the nifty one, so the nifty system is only rendering and my system is managinbg buttons clicks and other controls.

But the mouse is still randomly grabbed if i remove the Mouse?setGrabbed(false).

You shouldn’t be calling LWJGL code directly really. Post your code (as simplified as possible!). Maybe it’s caused by the fly camera?

Sounds like you dug yourself a deep hole that only you can get yourself out of.


So i just made my own cam to handle properly rotations instead of using flybycam, and i got something good and something less good :

  • When you are ingame, it seams that physics colisions ar no longer buggy.
  • Still when you are ingame, there is a less number of FPS that are dropped.
  • But the whole Nifty Gui System wont work anymore… Now the Nifty system does no longer reconizing movement when you move your mouse. So no click possible, impossible to enter the game by the main menu : you need to hack the game itself to enter ingame…

Here is my Camera code (based on the flybycam) :

–Removed code because it’s not that–


Ok so i found the origin of the problem : it seams to be a problem with Nifty Mouse Input System itself ! I tried by changing the x and y coord of the nifty mouse at each ticks and it seams to be handling back a little part of inputs. The problem is that i can’t find a way to rewrite the nifty mouse handling system. The system needs to use the LWJGL because it seams like the JME mouse is not detecting correctly mouse corrds and events. Only LWJGL seams to be detecting correctly mouse input.

Nobody ? Realy nobody ?

If so, i will have not any other choice as using GL11 directly to make GUI !

What norman said, you are doing something very very wrong. I would start over and try again, maybee by following the tutorials.

1 Like

Sorry but i followed exactly the tutorial but it’s not working !

And if you realy don’t want to help, no problem i will use my 2d render engine !