Nifty Gui has problem with fullscreen!

I don’t know, if it’s just me! In window mode NiftyGui works perfect, any resolution, but as soon as I use fullscreen, I get bars that travel from bottom to the top of my screen, doesn’t matter which resolution I use. I think Nifty is too hard updating in fullscreen mode! Doesn’t affect my framerate!

Can you perhaps post a screenshot of the problem?

Sry! I tried, but it’s not possible. The screenshots look normal.

Yeah I know, it was a trick question :stuck_out_tongue:

Anyways, just enable “VSync” option in the settings dialog, or on the AppSettings object you pass to the Application.

I already used VSync. I reduces the “walking bars” number to one, but still it’s pretty annoying.

With window mode it’s working fine! Maybe NiftyGui is too heavy for jME in fullscreen. Looks like both layers try to get superior update controll!

The void inside the bar reflects the model behind the nifty gui

It seems like a hardware issue to me. It might be just more noticeable when nifty gui is running. Do other 3D apps also have this fullscreen issue?