[Nifty] Update/Render Text problem


I have a problem with the upgrade of the line of text on the console.

when I write and send the first line is rendered correctly, but from the second time the line is not updated, and renders a portion of the first line equivalent to the size of the last row.

Can someone help me?

can you provide a screenshot please?

If you don’t understand, I apologize because my english is bad.

Below is a screenshot with the problem:

  1. The first line renders correctly
  2. The second line renders correctly only if you have the same size as the first.
  3. In the third line is written ‘jmonkeyengine’, but was rendered ‘nifty gui’

    I also have a problem with the drop down list below:

    Should show a list like this: “800x600”, “1024x768”, “1400x900”, “1600x1050”

    But only renders correctly in ‘mouse over’

thanks for the screenshots! I honestly have no clue what’s causing this issue O_o are you on some odd hardware with maybe a bad graphics driver or something? since you’ve posted here you’re using jme3. can you try this with the native lwjgl nifty renderer for comparising? I can probably help you to set this up.

currently I don’t have another idea and I haven’t seen this odd behaviour mentioned somewhere else yet :confused:

1 Like

Problem solved!

I changed the render to opengl1 and now it’s all right.


Thanks for the help.

If you switch to OpenGL1 mode you’re introducing a lot of issues that come with it.

Perhaps you can make a test case XML file that shows the issue?

The change is temporary, it solved my problem.

Soon I will do tests on better hardware with OpenGL 2 and put the results here.

I use only Builders Class, XML only for styles and controls.

But it’s probably the hardware, right?

It could be a lot of other things, I wouldn’t say it has to be the hardware

I tested on another computer, and has been rendered correctly with OpenGL 2.

So I come to the conclusion that the problem is in hardware.