No compile errors, no errors in log but also nothing visible

Ok, I downloaded the JME from SVN this afternoon. Followed the video tutorial to configure it and all seemed to work. I got rid of all the build errors without to much problems. But now, when I try and run one of the jmetest classes, I just get a black canvas with nothing on it. And the console just shows info messages, so nothing seems to be going wrong.

I have no idea what could be causing this bth. and I never had this problem before (with jme1).

I've tested on many machine/gfx board combinations (ATI and NVIDIA under XP).

The problem can be easily replicated.

Is this an LWJGL issue ?

As Jenne stated earlier, the problem seems to originate from which would explain why JOGL works and LWJGL does not.

I think it's time to raise this as a real bug through the issues page.

the problem was introduced by this patch it does not show up with the jogl renderer because the author never got jogl to work for him and couldn’t test it, I can state however that my standardgame app has shown no ill effects from this…that I can see :?


I have the same problem.

When i try to run the “HelloJme” tutorial application (as seen in the tutorial videos), it will just display a black window (no errors in the console).

I tried to run the demos from with various results.

The island demo just crashes but the others run with no problems.

I run on a AMD Phenom 9550 with a GeForcee 8800GT (driver version

Maybe someone could help?

[edit: Updated my driver to version (the latest). Problem still exists]

Ok, I did some more testing and it turns out some test classes work and some don't.

Not sure why that is yet though but I'm not that into JME to make a better search for that problem.

The TestSimpleQuadWater test class works, but the TestParticleSwarm class does not. The only thing that jumps out for me is that they both extend a different parent class. Not sure if that could have anything to do with it though.

I'll keep looking for the exact problem, but it seems like there's something wrong with the tests, when one works and one doesn't. Doesn;t look like a problem in compatibility with my system in any case.

Same Here: black LWJGL window with many JME tests. Not all i.e.

not working (some examples):







Simple workaround: just hit F4 (display stats) and you'll be able to see the scene again.

I'm using the latest JME from SVN.

On WinXP sp3 / NV GTX 260 (driver version 191.07).

I tried with a previous version of JME and everything works as expected. Does this problem relate to one of the latest RTT fixes introduced in the 4729 release ?

I've verified the revisions. The problem occurs since Revision 4729.

In detail the class which is responsible for this problem is

the changes in the DisplaySystem classes are out of it.

At least the Skybox-Example is working with the old TextureRenderer

but not with the new one.

Haven't found the reason yet, because there are a lot of changes

between Revision 4727 and 4729.


Further investigations show's up that the problem is located within the constructor.

The else part of the if for buffer initialisation contains now the following code:

EXTFramebufferObject.glBindFramebufferEXT(EXTFramebufferObject.GL_FRAMEBUFFER_EXT, fboID);



colorRBID = buffer.get(0);


EXTFramebufferObject.glGenRenderbuffersEXT(buffer); // generate id

depthRBID = buffer.get(0);

EXTFramebufferObject.glBindRenderbufferEXT(EXTFramebufferObject.GL_RENDERBUFFER_EXT, colorRBID);

EXTFramebufferObject.glRenderbufferStorageEXT(EXTFramebufferObject.GL_RENDERBUFFER_EXT, GL11.GL_RGBA8,

                    width, height);

EXTFramebufferObject.glBindRenderbufferEXT(EXTFramebufferObject.GL_RENDERBUFFER_EXT, depthRBID);


                    GL11.GL_DEPTH_COMPONENT, width, height);


                    EXTFramebufferObject.GL_COLOR_ATTACHMENT0_EXT, EXTFramebufferObject.GL_RENDERBUFFER_EXT, colorRBID);



replacing this by the old code

EXTFramebufferObject.glGenRenderbuffersEXT(buffer); // generate id

        depthRBID = buffer.get(0);


            EXTFramebufferObject.GL_RENDERBUFFER_EXT, depthRBID);



                GL11.GL_DEPTH_COMPONENT, width, height);

results in a working skybox example (haven't tested the others).

I'm not familiar enough with this to find out what's the reason in the moment.

May be someone who knows more about it will be faster detecting the reason.


I also get a black screen for everything I try with LWJGL. (And JOGL works fine)

Schwiggy said:

I also get a black screen for everything I try with LWJGL. (And JOGL works fine)

I have the exact same problem described in this thread and can confirm also, jogl works fine, lwjgl doesn't.


just checked the new version in the SVN. LWJGLTextureRenderer is now working properly here.

(MacOSX 10.5)


sorry fellas,

my mistake. fixed it as stated above.