No project assets folder

Hi, i’m new to the jMonkeyEngine, and trying to figure out how to set up my project properly. I’m using jMonkey Initializer to generate a project, when I open generated project in SDK ( v3.4.1-stable), I don’t have “Project Assets” folder. I guess it is not automatically created, so I have to do it by myself, but can’t find any instructions. Any attempt to open j3o scene from other directory (e.g Resources/Scenes/) is failed, nothing happens. Appreciate any help in tracking down the issue

You can try the SDK Gradle template instead. Mix and match.

Also with Gradle you usually need to build everything first to get things going. But seems that there is also this bug File is not part of a jME project but tries to find original model · Issue #379 · jMonkeyEngine/sdk · GitHub. Unfortunately.

Thanks for the response, @tonihele. I tried to use sdk gradle template, but “Project Assets” node disappeared randomly, so I decided to use Initializer template instead.

Tried to compile sdk with this commit as well, but had no luck, “Project Assets” node is not created.

Oh yeah, seems to be really tricky… If you have the skills to compile and run the SDK. Then you absolutely should get it working. But it is complicated:

Roughly the process is as follows:

  1. Build the project
  2. Restart the IDE

I’ve finally been able to return my “Project Assets” by using latest snapshot (with :assets/assets workaround) and gradle template, many thanks for help!


Hi @apopov are you sure there were no assets folders? I just downloaded a test project and they were there?

Note that the initializer uses a normal gradle layout rather than the old jmonkeyengine layout. That means that the asset folders are at src\main\resources rather that within a top level assets folder (this makes a number of things much less of a pain)