[NoClassDefFoundError] - [setting_up_eclipse_to_build_jme]-tut


i'm not quite sure why this exception should be thrown if you start a app out of eclipse, it would mean that TestChoser.class is not in the class path but eclipse should take care of that.

Did everything compile without errors?

Try to clean the jme project and see if it builds fine.

If it still doesn't work, try delete the jme project and set it up again :slight_smile:

eclipse doesn't say anything, there aren't any compiling error, only the messega i wrote…

To delete and create it again… I have tried that several times, but nothing changes…

but you do get warnings (in the problems tab) when jme compiles right ?

there isn't anything, here i have a picture of that

hmm i don't know, it seems to me that the project didn't build at all.

i have same kind of problem, when i try to run teapot renderer test, it throws:

14.9.2008 17:38:31 com.jme.app.BaseGame start
INFO: Application started.
14.9.2008 17:38:31 com.jme.system.PropertiesIO <init>
INFO: PropertiesIO created
14.9.2008 17:38:31 com.jme.system.PropertiesIO load
INFO: Read properties
14.9.2008 17:38:32 class jmetest.renderer.TestTeapot start()
SEVERE: Exception in game loop
java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
   at java.lang.ClassLoader.loadLibrary(Unknown Source)
   at java.lang.Runtime.loadLibrary0(Unknown Source)
   at java.lang.System.loadLibrary(Unknown Source)
   at org.lwjgl.Sys$1.run(Sys.java:75)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.lwjgl.Sys.doLoadLibrary(Sys.java:68)
   at org.lwjgl.Sys.loadLibrary(Sys.java:84)
   at org.lwjgl.Sys.<clinit>(Sys.java:101)
   at org.lwjgl.opengl.Display.<clinit>(Display.java:111)
   at com.jme.system.lwjgl.LWJGLPropertiesDialog$ModesRetriever.run(LWJGLPropertiesDialog.java:669)
   at com.jme.app.AbstractGame.getAttributes(AbstractGame.java:219)
   at com.jme.app.BaseGame.start(BaseGame.java:62)
   at jmetest.renderer.TestTeapot.main(TestTeapot.java:61)
14.9.2008 17:38:32 com.jme.app.BaseSimpleGame cleanup
INFO: Cleaning up resources.
14.9.2008 17:38:32 com.jme.system.lwjgl.LWJGLDisplaySystem <init>
INFO: LWJGL Display System created.
14.9.2008 17:38:32 com.jme.app.BaseGame start
INFO: Application ending.

kinda annoying, could anyone plz help me, i have done that tut like 5 times no without any problems, jme just don

no lwjgl in java.library.path means that you need to tell your IDE, where to look for the native libraries (lwjgl.dll)

step 10