Non-armature blend file animation not working

I am going to try the ogre xml but when I tell it to install it from the SDK and point it at: “c:program filesblender foundationblender2.60scripts” it says it installs but there is no ogrexml option afterward when I open blender in the export menu item. I am obviously using 2.60. Should I be using 2.59?

It’s because you have to install it in blender too after that, via file


>user preferences
>addons.
1 Like

Thanks, I exported it with ogre and I can convert it to a j3o binary. The only problem is, I still can’t create an animation controller. I keep getting a null object reference. Now I rigged it and tried my rigging and ttrocha’s rigging. Both gave me a null reference when I tried to getControl(AnimControl.class) the spatial (which displays except for some reason without materials using ogre).

Make sure the material in blender has the same name of the model, and, how are you rigging your model? Is it an armature modifier with octadreal / stick bones connected to vertex groups?

Yes it is an armature modifier with octadreal/stick bones. I’m going to name the materials after the model.

If you want we can analyse your model for you ;).

Thank you so much. Here is the model: http://uploading.com/files/11d3796m/imp_1arma_00.blend/ :slight_smile:

First of all, you simply are using Bone Envelopes, it’s not supported by the engine.

Also, you are using two armatures for the same model. It won’t work, use one armature instead. And you you parented your wings model to the armature node, do not do that. I saw you don’t make your models “smooth”, you should. Also, you should apply the mirror modifier before exporting.

That’s a good analysis. I noticed some people had parented armatures to objects and that’s what I was trying to do at the time. Was there ever a policy to parent those two?

There’s no need to parent armatures to objects once armatures aren’t nodes in jme, and armatures doesn’t exists at all. The BlenderLoader system has a ArmatureModifier object, but that is just fot read the armature parameters. For armatures, you only parent bones to bones. You was using the Bone Envelopes for the rigging, but it’s not supported, you have to use Octadreal or Stick or B-Bones and assign them to Vertex Groups. The bones have to match the name of the respective Vertex Groups, otherwise it won’t work. There are nice sources of blender tutorials around there, my favorites is blendercookie.

I’ve got a model successfully converted into my jme3 project but I can’t run a model.getControl(AnimControl.class) successfully. It returns a null everytime! Is anyone else having this problem.

Yes, most solved it by having just one root bone. You can look in the SceneComposer for the AnimControl, if theres multiple they are available on each spatial and not on the root node.

I see the AnimControl but I can’t get at it in the code. It’s nested 3-4 deep into the model’s nodes.

xD what name is the node? Just go rootNode.getChild(“that_name”); and it will grab it for you no matter how deep.

This domain name is for sale. 100,000 USD

This domain name is for sale. 100,000 USD

Stop it, I won’t download the image anyway when having to wait 40 secs :stuck_out_tongue: Read my post!

http://imageshack.us/photo/my-images/846/impnodes.jpg/

Sorry that should fix it

I figured it out. You have to attach it to a node then run a getChild to find the name of the appropriate node that has the animation. Sorry for the forum disruption! :frowning:

Yeah, there you go, a perfectly non-null AnimControl :roll:

Again:

[java]AnimControl control = model.getChild("body-ogremesh").getControl(AnimControl.class);[/java]