Non svn eclipse svn jme2 instal

Hey all, and thanks in advance for reading my post. Basicly me and five of my freinds are wiritig a game in the jme and we can't run forgein exe files on our college computers, this means we cannot use svn programs. But we do have a new version of eclipse on them, now I am a total eciplse noob, any idea on how to get jme2 working?

You can use the brand new snaphot jars:

That way you don't need to build the jars from source by yourself.

I think there is no wiki entry which explains how to use it, but see this thread for more infos:

oh wow cheers, i might add this to the wwki if you wish, as alot of people are lazy and don't read the forums coughmydevelopmentteamcough :smiley:

How are you running that?

If its from Eclipse you will need to point it to where the natives (lib/natives) are; dunno how to do that I am a NetBeans user :wink:

going in eclipse with my project and right clicking on the .class file run as java aplication

Just to test the natives will you either run the run_jME batch file (.bat for windows, .sh for everyone else)

Or run this command:

java -jar -Xmx256m -Djava.library.path="lib/natives" jME_2.0.jar

ok cool thanks alot for the help so far, ive got those demos running now. But i have another problem, for some reason when i follow the guide here: i have JRE system’s libary and jME jar under referenced libairies and also src under the porject. Then under src i have default package, then my lesson1 file under that.

Ecplise is telling me: ALWAYS_SHOW_PROPS_DIALOG cannot be resolved


Texture.MM_LINEAR_LINEAR cannot be resolved

Texture.FM_LINEAR cannot be resolved

with the red error underline. (sorry if this i basic stuff but i can’t see any wiki which covers this kind of noobishness)

The source in the wiki is motly based on jme1.

Its best if you look at the source in the downloaded zip.

In the jmetest package, you find the source for every test.

Or here:

Ok thanks I managed to get it running on my home computer now. I've just treid the same at college, importing the jar file from the zip worked fine, but when copying the lib foler into the poject folder, unlike at home, nothing shows up in eclipse even after rebooting it. I think it may have to do with the fact the college version is Eclipse SDK Version: 3.2.0 not ganymede or whatever the new one is called. I tested it just to make sure and the sample code you linked to on google, the first line (package jmetest.TutorialGuide;) throws this error:  The declared package "jmetest.TutorialGuide" does not match the expected package "". 

thats probably because you copy pastes the HelloWorld Code into your own new project, with no package declared. (it shows as default package in eclipse)

if so, just remove the package declaration: "package jmetest.TutorialGuide;"  from your code.

Again i can't thank you enough for your time :slight_smile: My college computers with Eclipse SDK Version: 3.2.0 still doesn't seem to recognise that i have copied the lib folder into the project, and at home when it try hello world i can run it, but the console gives this error and nothing dispalys:

28-Jan-2009 15:53:31 start

INFO: Application started.

28-Jan-2009 15:53:31 com.jme.system.PropertiesGameSettings <init>

INFO: PropertiesGameSettings created

28-Jan-2009 15:53:31 com.jme.system.PropertiesGameSettings load

WARNING: Could not load properties. Creating a new one.

28-Jan-2009 15:53:31 class HelloWorld start()

SEVERE: Exception in game loop

java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

at java.lang.ClassLoader.loadLibrary(Unknown Source)

at java.lang.Runtime.loadLibrary0(Unknown Source)

at java.lang.System.loadLibrary(Unknown Source)

at org.lwjgl.Sys$

at Method)

at org.lwjgl.Sys.doLoadLibrary(

at org.lwjgl.Sys.loadLibrary(

at org.lwjgl.Sys.<clinit>(

at org.lwjgl.opengl.Display.<clinit>(

at com.jme.system.lwjgl.LWJGLPropertiesDialog$



at HelloWorld.main(

28-Jan-2009 15:53:31 cleanup

INFO: Cleaning up resources.

28-Jan-2009 15:53:31 com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.

28-Jan-2009 15:53:31 start

INFO: Application ending.

Did setup the library path in your runtime arguments in eclipse correctly?

(ex: -Djava.library.path="lib/natives")

no, how do i do that?

any ideas?

It should be in the tutorial, if not search the forums (or just google it)…