i am getting this error when trying to run the lesson 8 example program for jme physics:

java.lang.NoSuchMethodError: com.jme.renderer.ColorRGBA.set(Lcom/jme/renderer/ColorRGBA;)V

at com.jmex.physics.material.Material.setDebugColor(

at com.jmex.physics.material.Material.<clinit>(

at com.jmex.physics.PhysicsSpace.getDefaultMaterial(

at com.jmex.physics.PhysicsNode.getMaterial(

at com.jmex.physics.PhysicsCollisionGeometry.getMaterial(

at com.jmex.physics.impl.ode.DynamicPhysicsNodeImpl.computeMass(

at com.jmex.physics.impl.ode.DynamicPhysicsNodeImpl.setCenterOfMass(

at Lesson8.simpleInitGame(

at Source)

at Source)

at Lesson8.main(


at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(

at sun.reflect.DelegatingMethodAccessorImpl.invoke(

at java.lang.reflect.Method.invoke(

at bluej.runtime.ExecServer$

line 85 reads…

player.setCenterOfMass( new Vector3f( 0, -0.5f, 0 ) );

anyone know whats going on?

EDIT: i just tried re downloading jme and i still get the problem…

according to an older post its something to do with the versions, does anyone know which 2 i should have which match?

You are using incompatible binaries of jME Physics 2 and jME - recompile jME Physics 2 or use the jME Version which comes with your jME Physics 2 binaries.

I will release a jME Physics version 2.1 which works with jME 1.0, soon.