Not Copying Library \assets , it's a directory

Hi there,

I’m trying to build my project and I get the following error

Not copying library C:\Users\Bawb\Documents\GitHub\Oregon-Trail\Oregon Trail\assets , it’s a directory.

I don’t understand why this is the case and I can run the game just fine. Does anyone have any advice?

Thanks for Reading

Did you start out with a BasicGame project? A normal java project won’t manage the assets folder by default. Also make sure that in your project properties under “Build->Assets” the correct path and asset jar name are set.


Yes I always start with the basic game. Under Build assets it seems to be right… it just says “assets.jar”

It doesn’t seem to be any different from my other games


Somehow this was solved by enabling Android deployment, and cleaning and building. Why this worked, I can’t say, but that solved it.

I got the problem @normen
The problem lies in uncoupling of build xmls. This means that project structure changes but build xmls stop to refresh! I got this problem when I exported my project to intellij idea. I got the same problem but I don’t know there is any way to relink build xmls! My build xml works for desktop config but not working for android just inverse of @BigBob problem. But he could force build xml to rebuild but in my problem build xlm only compiles desktop files even when I check develop for android and in last steps of compile gives that error.
also in post:

somebody could rebuild xmls by renaming assets folder but it doesn’t work for me! And IDE only runs desktop even when I check Develop for android and select Android device config!
Is there any way to regain build xml autogeneration back?