Object walking BUG report

i dont know if u guys have ever noticed this problem, but in the TestObjectWalking, u can actually walk into the boxes.



when u try to walk onto the box, u actually walk into the box first then when u almost reaches the center of the box, u suddenly jump onto its surface.



but this problem doesnt exist if u walk backwards to get on the box.



i think this is directly related to my second problem i mentioned in another post~



my problem was i tried to move my player which is a model on another model. very similar to the test object walking. but my player couldnt move to the edges of my terrain model when the camera is facing towards the edge. but it works fine if the camera faces away from the edge. and btw, my terrain model is a box for now.



plz look into it thx~  :expressionless:

so em…is this really a bug or im just over reacting?

TestObject walking does not do object colliding, just setting the height of the walk. So, you don't walk on the box until the center of the camera is over the object, in some cases causing the view frustum to enter the object.

mojomonk said:

TestObject walking does not do object colliding, just setting the height of the walk. So, you don't walk on the box until the center of the camera is over the object, in some cases causing the view frustum to enter the object.


thx for the reply~sry for the misunderstanding

Do you think it would be very resource expensive, if you add the Picknode (=Objects you're walking on) to a StaticPhysicsNode? (the meaning of this: player is not affected by physic, but everything else standing on the "floor")