Objects are not completely exportetd in Blender3D

Hi @all,

my Problem: Objects with only one image on one face are not completely exportet in blender 3d with the orgre exporter.

Cube with an image on a face:

Only the vertexes of the face with the image where exported

Should i put always an image to all faces of an Object?

Seems like a bug in the exporter, it doesn’t handle correctly when different faces of the model have different textures applied.

Try instead using “Rendering Materials” instead of “Game Engine Materials”.

“Try instead using “Rendering Materials” instead of “Game Engine Materials.”

If im doing so then the image is not displayed :(.

You have to set up the material settings for the object in the material menu.

You can read about blender materials here:


I’ve done like it was written, but the results look like this:


You don’t have a texture set on the material, since the material sphere is white.

If you want to view your model in Blender3D how it would appear in jME3, you can enable GLSL materials: go to Game → Blender GLSL materials

Thx it works fine know :).

One litle problem left: faces i haven’t set the image are showing the image either,

You need to use two materials per mesh and then assign the materials to the appropriate triangles.