Ogre Animation / Skeleton issue


I’m hoping someone can give me some hints to as what is causing an issue i’m facing with one of my imported ogre meshes.

I’m using attachments which follow the model most of the times, but when playing some animations, it’s as if they’re snapped “down” some distance. This location corresponds to the location the model would have if i use center() on it.

I could understand if it happened on all animations, since the skeleton doesn’t necessarily have the same worldspace coords as the model, but why only on some? I’ve checked the animations in Blender and everything seems fine there.

Any ideas on where to look?


This might actually be a bug in jme, we’ll have to check on that. @Momoko_Fan: any idea?

Does this happen with specific models or all models you tried? Are those models under physics nodes?

I’ve only tried it with one model. I’ll see if i can replace it with another today.

No physics, just regular animation.

I thought i was onto something when i realized it seemed to happen when the model was also moving. So i went on to modify TestOgreAnim.java to produce a test case. Oto did however not behave in the same way, so i guess this is a content error, after all.

Isn’t that a Edit mode/Object mode confusion in blender?

It reminds me of a similar problem. This can append when you adjusted the skeleton to the mesh in object mode instead of edit mode.

The result is that the rotations, translations and scales are not applied to the skeleton.

check this thread


In this thread i explained to blur how to do in his particular case, can be different in yours, but the idea is the same.