Ogre Import - Colors completly different

Hi,
On my computer at home I worked on a project a few weeks long. Everything worked fine. Today I copied the project and pasted it on my notebook, to work in the train and university. On both computer the same version of jmonkey is installed. I just opened the project on the notebook and checked if everything was imported right, which was the case. But when I start the game, the colors of 3 objects(which appear multiple times in the game) are complety wrong. All the others are right. You can see the texture on the model, but the colors are wrong and nowhere near the same as the orginal texture. But if I open the image file, its alright. I also reexported the ogre data on my notebook and I also imported the blender file directly in Jmonkey and converted it to j3o, but it all fails.
Does someone got an idea how this is possible?

Difference of hardware maybe.
Are you(re notebook’s graphic drivers up to date?
Maybe you have an integrated intel GMA card that are known to have issues with opengl 2.0.