Ogrexml animation

Hi everybody.

I'm trying to export an animated model from 3ds Max to jME using OgreMax. I can load the model no problem but I can never seem to keep the animation on exporting it, i.e. the following code throws the exception.

if (getChild("body").getControllerCount() < 1)
             throw new IllegalStateException(
                     "animations are missing");

SEVERE: Exception in game loop
java.lang.IllegalStateException: animations are missing
at player.Player.playAnimation(Player.java:49)

I can load the example ninja model using my code and it works fine ... has anyone had this same problem? I imagine it has something to do with my settings in OgreMax or something but I really have no idea!

If anyone can point me in the right direction it'd be a big help.

I don't really know. I never got skeletal ogrexml animations exported from 3dsmax working altough I tried to follow all the cotchas like having only one rootbone and u can't use some fancy tools of making models and animations that max allows. So eventually I had only option to use md5 format, but it in turn had problems cuz 3dsmax uses right-handed coordiinate system and JME left-handed or vice versa. So I had to move, rotate the model to get it to the right place.

Only animation that I made myself and got working in JME with ogrexml was a textured box moving around.

I reccommend u to have lots of patience when trying to get ur max animations to work in JME. It took me like 2 months to figure it out.

But many ppl have had lots of success with ogrexml and there is eaven a blender->ogrexml->jme tutorial at wiki page.

Henri said:

I never got skeletal ogrexml animations exported from 3dsmax working altough I tried to follow all the cotchas like having only one rootbone

In ogrexml for JME you can now have more than one root bone, that gotcha only applies to MD5.

I've come across this error when exporting from blender because my *.skeleton.xml file didn't have any animations in it.  It had bones, and the hierarchy, but no animations.  I fixed this in blender by setting my model to get out of "Rest Position", because when it was in this mode it wasn't moving the bones for the export script.  It could be drastically different for 3DMax, but maybe you haven't selected which animations you want to export in the OgreMax script.  Could be some other problem, but in the end the *.skeleton.xml file referenced by your *.mesh.xml file must have your animations in it.

Look at the ninja xml files for reference:

There are a lot of guides on the Ogre3D site and such that help you use the various exporters. The OgreMax exporter is the best supported one so there shouldn't be an excuse to check the vast documentation that comes with it: