OpenGL 2 on Linux

Hey guise.

I just started using jME, and decided to try the BasicGame project in the jMonkeyPlatform.

When i start jMP i get an error saying: “Error opening OpenGL window”, and that my graphics card doesnt support opengl 2.

Ive got a ATi HD4890 with the newest drivers, so i dont think that should be the problem.

When i try to run the game i get this error: “org.lwjgl.LWJGLException: Could not choose GLX13 config”

Anyone got an idea of whats wrong?

It does not say that your card does not support OpenGL2, it just mentions that it needs to be compatible and that you should check your drivers, look in the forum, there seem to have been changes in Ubuntu/Linux/Windowmanager that break the lwjgl canvas somehow.

Are you sure you have the latest drivers? The GLX13 error is generally because you don’t have the correct ones installed

Thx for the replies.

I downloaded the package with catalyst 11.3 yesterday, and installed without any errors.

Ive also tried with those in the driver-manager, but still didnt work :confused:

Do any other OpenGL applications run?

Nope, dont think so. Compiz?

From the output when i start jMP:

EDT: Creating OGL thread.
Using LWJGL 2.7.1
Display created.
Adapter: null
Driver Version: null

What I meant was, did you try running other OpenGL applications on your PC?

While at it, are you running compiz on it as well?

I’ve played minecraft on it, and it works perfect.

And yea, compiz are running:P

Can you please post the entire log when you run the game?

Building jar: /home/joachim/jMonkeyProjects/Joachim/build/assets.jar
Updating property file: /home/joachim/jMonkeyProjects/Joachim/build/
Created dir: /home/joachim/jMonkeyProjects/Joachim/build/classes
Created dir: /home/joachim/jMonkeyProjects/Joachim/build/empty
Compiling 1 source file to /home/joachim/jMonkeyProjects/Joachim/build/classes
Apr 4, 2011 12:23:20 AM com.jme3.system.JmeSystem initialize
INFO: Running on jMonkey Engine 3 Alpha 0.6
Apr 4, 2011 12:23:20 AM com.jme3.system.Natives extractNativeLibs
INFO: Extraction Directory #1: file:/home/joachim/jmonkeyplatform/jmonkeyplatform/libs/
Apr 4, 2011 12:23:20 AM com.jme3.system.Natives extractNativeLibs
INFO: Extraction Directory #2: /home/joachim/jMonkeyProjects/Joachim
Apr 4, 2011 12:23:20 AM com.jme3.system.Natives extractNativeLibs
INFO: Extraction Directory #3: /home/joachim/jMonkeyProjects/Joachim
Apr 4, 2011 12:23:20 AM com.jme3.system.lwjgl.LwjglAbstractDisplay run
INFO: Using LWJGL 2.7.1
Apr 4, 2011 12:23:20 AM com.jme3.system.lwjgl.LwjglDisplay createContext
INFO: Selected display mode: 1280 x 720 x 0 @0Hz
Apr 4, 2011 12:23:21 AM handleError
SEVERE: Failed to create display
org.lwjgl.LWJGLException: Could not choose GLX13 config
at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo(Native Method)
at org.lwjgl.opengl.LinuxDisplayPeerInfo.(
at org.lwjgl.opengl.LinuxDisplay.createPeerInfo(
at org.lwjgl.opengl.Display.create(
at org.lwjgl.opengl.Display.create(
at com.jme3.system.lwjgl.LwjglDisplay.createContext(
at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(
Apr 4, 2011 12:23:21 AM handleError
SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]
java.lang.IllegalStateException: Cannot determine close requested state of uncreated window
at org.lwjgl.opengl.Display.isCloseRequested(
BUILD SUCCESSFUL (total time: 6 seconds)

There you go

Hmm, now it works without AA(thats what it is right?).

I’ve tried without it before :S

Yes its possible the AA is overridden, it is generally loaded from registry.

Now I see, you specified AA values that your video card does not support …

I tried with AA x2 too, but it crashed then also…

But anyways, thanks for your time :wink:

I’m having a similar issue, Ubuntu 10.10 64bit, latest nVidia drivers (card - gtx470), if I turn on AA I get GLX13 error… the card runs 16xAA (JME game) without hesitation when running Windows 7.

I got a GeForce 9500m GS 512 MB graphics card and got an error too. It’s saying that it doesn’t support OpenGL 2.0, but I checked it on Google and found that it should be supported up to 3,3

I run Linux Ubuntu 11.04 Natty 32 bit.

The jMonkey Engine was running but after some updates came up it stopped working, showing me that error.

Any solutions?

You can have the best video card ever made but if you don’t have proper drivers installed its as if you don’t even have OpenGL1 on your system. On Ubuntu there’s a “hardware drivers” menu where you can install proprietary drivers for your card

1 Like

Same for me, the very first time I installed it worked but after updating it doesn’t work anymore. But when launch an application or a test it does run fine in opengl mode at 500fps+.

For me I found a way to make it works :

I play starcraft 2 through wine and crossover, and sometimes If I lauch jmonkey platform right after exiting starcraft2 I don’t get the error message and the scene works (not 100% of the time).

nvidia gt240 + fedora 15 x86_64 with official nvidia driver.