OpenGL Error 1280, have not clue what it means


I’v checkout the latest jme3 and then I imported the jars needed to not get any error in my game.

I’v imported:







But when I run my game, It manage to render the game once, then I get the following error message:

:26:06.731: E/AndroidHarness(6262): com.jme3.renderer.RendererException: OpenGL Error 1280. Enable error checking for more info.
E/AndroidHarness(6262): at
E/AndroidHarness(6262): at

I can see the planets and the sun, my rocketstation etc with no problem, but only for a glimps of a second.
Then this error pops up. And I dont know how to enable error checking.
So what should I do?

it’s fixed in last revision

I checked out jme again and put it in the place of my previous jme checkout.

But the problem still remains… Should I click some update buttom instead or something?

I go in properties, and click svn info and it says “property status: not moddified”

So Im guessing that meens I have the latest version right?

Maybe the error remains?

:facepalm: you sure know how to screw things up…

Just update your jme project yes…but you may have to rebuild it.

I’m so sorry that I do mess all up, but I promise you all a free version of the game upon release :stuck_out_tongue:

Im not sure what build meens, doesn’t eclipse do that automaticly?

I did run the build.xml ant file but when I ran my android game it said nothing had changed so it did not need to upload it again to the cellphone.

So I added a println in the activity to make reinstall the game and it did. But the error remains…

1 Like

Turns out I’m not even using the svn! What?!

For some reason I was still using an old nightly build.

So I tried to use the checkout jme. Problem is, it does not contain the jars I need.

As said, my game runs if it got access to these jars:

  • jME3-android.jar

  • jME3-core.jar

  • jME3-plugins.jar

  • stack-alloc.jar

  • vecmath.jar

  • xmlpull-xpp3.jar

But it does not. I can not find them.
I do find vecmath and xmlpull and stack-alloc.
But jME3-core does not exsist
jME3-android is replaced by android.jar?
jME3-plugins can not be found.

What am I doing so wrong?

1,2,3 or 4?

1 Like

Ill take whats behind door number 1 :smiley:

Wee! #4 doesn’t set paths to the JDK it installs, it doesn’t work out of the box for the SDK.

So your saying 4 was the correct answer?


It’s door number 1. normen is just sarcastic . Okay I did have that problem but that’s just because the stupid OpenGL check just flaged the version and I modified it so it didn’t happen again. Anyways, the new updates should be working now. When you use the svn with eclipse, you have to build it with JDK and not JRE. Don’t assume the jars will be there just because you use svn Checkout.


Ahh okej.

I assume building is when you run the build.xml as an ant file in eclipse.

I did that but I got:

Buildfile: C:Program FileseclipsejME3svnbuild.xml
[delete] Deleting: C:Program
[propertyfile] Updating property file: C:Program
[echo] Compile Core
[javac] Compiling 471 source files to C:Program FileseclipsejME3svnbuildcore

C:Program FileseclipsejME3svnbuild.xml:39: The following error occurred while executing this line:
C:Program FileseclipsejME3svnnbprojectbuild-impl.xml:346: Error running javac.exe compiler

Total time: 1 second

What it says is:
C:Program FileseclipsejME3svnbuild.xml:39: The following error occurred while executing this line: gensrcdir="${build.generated.sources.dir}"/>
C:Program FileseclipsejME3svnnbprojectbuild-impl.xml:346: Error running javac.exe compiler:
<javac debug="@{debug}" deprecation="${javac.deprecation}" destdir="@{destdir}" encoding="${source.encoding}" excludes="@{excludes}" fork="${javac.fork}" includeantruntime="false" includes="@{includes}" source="${javac.source}" sourcepath="@{sourcepath}" srcdir="@{srcdir}" target="${}" tempdir="${}">[/xml]

Not sure what this meens or what to do really..

Okay, In eclipse go to

  • Windows
  • Preference
  • Java
  • Installed JREs

    In Installed JREs, does it only show jre7?
1 Like

it says jre6 only.

I think I did install 7 before but it didn’t work so I uninstalled it…

So it doesn’t show jdk on there?

1 Like

No, should it?

I meen the submenu is called installed jre’s right?

Okay, in that same window, the Installed JREs window.

  1. Click the Add… button that’s on the right.
  2. Add JRE Type windows pops out, hightlight Standard VM then click next.
  3. JRE Definition windows pops out.
  4. For JRE home: click the Directory button.
  5. Look for you jdk folder. For example mine was C:Program Files (x86)Javajdk1.7.0_01
  6. Then click Finish.
  7. Now check the jdk1.6 in you Installed JREs. Then hit okay.

    Now you can build.
1 Like

I did as you told, but I use jdk 1.6.0_30 but it gave same error as before when running the build.xml ant file.

I assume I must download jdk 1.7 something for this to work?

Okay, I guess you have to use Ant build through Edit Configuration.

1 Like