Package does not exist

Hello, I am very new to this java and jme thing. Coming from experienced C++/DirectX background.

I’m trying to use jme on android, with jMonkeyPlatform.

I have built jMonkeyEngine3.jar on windows with ant but when I do import I get an error: package does not exist. I have added path to jar to classpath:

[java]C:/Users/Simon>echo %classpath%


What am I doing wrong? Is it because I dont have a .classpath file in my project?



btw, had to change the backslash to forward slash to make it appear on this forum

Just update to nightly and use the android deployment functionality:

Nightly? I don’t understand :slight_smile:

I have Alpha 4 SDK and jme3.jar built from SVN.

In the nightlys folder, the latest is 2011-08-29. Which is right?


I unpacked 2011-08-29 and found the jME3optandroidjMonkeyEngine3.jar

So I corrected my CLASSPATH environment variable to this new location, but still the same error:

package does not exist

go tools->Plugins->Settings

there is option to check nightly version. set it on and you will be able to update nightly updates

if you cant run it, just download already nightly version

In the SDK, go to Tools->Plugins->Settings, enable the nightly update center, update the SDK and then go on according to the instructions in the link. You don’t need to build anything yourself, the plugin contains the latest version of the android jMonkeyEngine3.jar.

Drat! You beat me! I just found the nightly setting myself :slight_smile:

Thanks anyway. Very excited to get started with the great app.

Hey guys i got the same problem it always says

package does not exist


package does not exist

i updated to Nightly and i also did it manually nothing worked i looked in to the zip file to locate the but it i cant find it, the package does not contain it.

greetings dani

can anyone help me please ? :frowning:

Have you followed the step by step instructions on installing for android?

To test try creating a brand new project just displaying an unlit cube, follow the steps carefully, and deploy to android.

If that works you know you have some config wrong in your other project, if not then it’s something more serious…

ok now it works but i got a new error when running the project

Install file not specified.

‘ant install’ now requires the build target to be specified as well.

ant debug install

ant release install

ant instrument install

This will build the given package and install it.

Alternatively, you can use

ant installd

ant installr

ant installi

ant installt

to only install an existing package (this will not rebuild the package.)

D:sonstigesSchuleJmonkeyBasicGametestnbprojectmobile-impl.xml:5: The following error occurred while executing this line:

D:ProgrammeAndroidSDKtoolsantbuild.xml:1088: The following error occurred while executing this line:

D:ProgrammeAndroidSDKtoolsantbuild.xml:1150: No message

BUILD FAILED (total time: 2 seconds)

i googelt for a solution but all i found was updating android sdk and monkeysdk but it did not helped…

i dont understand what have i to do now ?

Help find the issue in android SDK.

1 Like