Particle Effect Won't show at Certain Angles

Hey everyone. I posted something similar much earlier, but I was too unclear for you all to be able to help me. I have this torch with a fire particle effect on top, and you can only see the full particle effect when you have one specific camera angle. From most angles, you can hardly see it at all! I figure this is a common problem, because the effect I’m using is an exact copy of what is seen in the example on Hello Effects. Just to be safe though, here is the code.

fire = new ParticleEmitter(“Emitter”, ParticleMesh.Type.Triangle, 30);
Material mat_red = new Material(assetManager, “Common/MatDefs/Misc/Particle.j3md”);
fire.setImagesX(2); fire.setImagesY(2); // 2x2 texture animation
fire.setEndColor( new ColorRGBA(1f, 0f, 0f, 1f)); // red
fire.setStartColor(new ColorRGBA(1f, 1f, 0f, 0.5f)); // yellow
fire.getParticleInfluencer().setInitialVelocity(new Vector3f(0, 2, 0));
rootNode.attachChild(fire); /** Explosion effect. Uses Texture from jme3-test-data library! */

I just want to be able to see my torch >.> Any thoughts?

could we see some screenshots? I generally only get that when using setFacingVelocity() or setFaceNormal(), by default the particles should align to the camera

I can’t do a screenshot because my mouse dissapears when I play the game and I’m not going to change the code for screenshots. But it really is as simple as I said it was. You can see it from some angles, and you can’t from others. Is there any chance that it could have to do with the lighting on the scene?

You don’t have a screenshot button on your keyboard?

Anyway, the only code you need to add to get the mouse back is :

You can also just press alt tab and it will release the mouse capture. But the print screen key is the best option.

To be honest it sounds like the billboarding mode is set up wrong - so the particles are all always pointing in the same direction.

The particle controller stuff might be worth you experimenting with if you are going into particles: