Particle Effects always being rendered behing the model

Hi guys!

I have a bug in which my particle emitter is still visible behind a model. In the material, the DephtWrite is already checked, and this bug doesn’t occur in SceneComposer. So, what am i missing?

Guys? Can somebody explain me? Because that’s an annoying bug…

You haven’t given us any useful information for helping to solve the problem. Sort of like: “I’m holding a piece of string. Can anyone tell me how long it is?”

Pictures of what you mean. Code showing how your emitter is setup. Code showing how the object is setup. Otherwise, we are making blind stabs in the dark.

Try removing all the filters, including bloom, shadow etc. Then play around with transparency filter - see how scene looks with it being enabled or not. If one of these combinations lead to proper look, then it might be the issue with order of filters.

I always had major problems with getting shadows, translucency and bloom working properly at same time - and translucent objects shining through the opaque geometry was most common indication something is wrong.

Thanks @abies for your help and excuse me @pspeed for the lack of information.

I deactivated all of the filters i was using, and it actually worked! But, when i reactivate one single filter, it bugs again. Here is the list of filters i’m using and in the order when they are created:


Any of these will make the particles being rendered behind the model. So, i suppose the filters are being called in the wrong order.

But, these 3 filter are called in the Main.class, and the particles are in my terrain.j3o

What is the correct order and how i can change it?

Is the model in the transparent bucket? (The particles probably are… but maybe not.) Can you show us a picture of the issue? One with and without filters would be nice. It would answer about 50 questions.

Otherwise, the only advice I can give is to make sure that the particles and the model both are in the proper buckets. As far as filters go, shadows should be first. I think water should be last.

The terrain is Opaque, and the particles are Translucent. I think there’s no problem withe the bucket.

So, here comes the pictures you asked (sorry for putting the links, the pictures didn’t shown up):

1 - The terrain in SceneComposer. There’s no water, sky and any other filters. The particles are ok.

2 - Here you can see that the particles are not being renderer behind those mountains.

3 - On the game, it is running without any filters…

4 - …and the particles are fine.

5 - When I finally load up the filters, this happens:

On the particle’s material, the Blend mode is AlphaAdditive, and the ColorWrite and DephtTest buttons are checked.

I ran the shadow filter first, then the bloomfilter and at last, the water. Still doesn’t work.

@Ev1lbl0w said: The terrain is Opaque, and the particles are Translucent. I think there's no problem withe the bucket.

Translucent or Transparent? The first requires the translucent filter to be in the filter stack. The second doesn’t.

Thank you so much @pspeed! Setting the bucket to Transparent did the job!