Please help......The binary file is of newer version than expected!

java.io.IOException: The binary file is of newer version than expected! 2 > 1

at com.jme3.export.binary.BinaryImporter.load(BinaryImporter.java:169)

at com.jme3.export.binary.BinaryImporter.load(BinaryImporter.java:147)

at com.jme3.export.binary.BinaryImporter.load(BinaryImporter.java:131)

at com.jme3.asset.DesktopAssetManager.loadAsset(DesktopAssetManager.java:243)

at com.jme3.asset.DesktopAssetManager.loadModel(DesktopAssetManager.java:376)

at com.jme3.asset.DesktopAssetManager.loadModel(DesktopAssetManager.java:386)

at testMethod.NewClass.simpleInitApp(NewClass.java:26)

at com.jme3.app.SimpleApplication.initialize(SimpleApplication.java:230)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:129)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.r







i don’t what should i do with this kind of error. do u encounter this kind of error?

if yes, how did u do to solve it?thanks

You probably used the nightly at some point and now try to go back to stable or you were using the latest stable updates and now are using vanilla beta.

yes, i made coding and the terrain in a latest stable updates and i change my workspace but it is not yet updated so i update it to view what i’ve done but i got this error. what’s wrong about it? thanks normen

You created files with a newer version of JMP and now you are running an older version and it can’t read those files.



It would be like trying to get MS Word 95 to read MS Word 2010 files. It’s just not possible.



You need to update to at least the same version that you used to create the files.

but yes i now already updated jmp to the same version i’ve used on the other workspace but still i get this error. maybe i missed something i’ll try to check it again. thanks for the reply