Plugin Nightlys not working in my SDK

Hey :smile:
I chose Troubleshooting as I don’t know if it’s my SDK or maybe the nightlys are simply disabled.

Kaelthas did a fix in BlenderImporter I’d need.
I am using the 3.0 SDK (Installed in Dec '14) so when I tried to update everything, I was surprised that infact there was no single update.
I enabled the nightly builds under the plugins menu, but somehow it returns zero plugin updates.

I checked the xml and it’s indeed “empty”. Are the nightlys only supported when using a 3.1 (nightly) jmp?

Or are they gone as the used to be?

Edit: I tried to compile the plugin on my own using the git repo, however I only have JDK Version 6 but grgit needs 7

3.1 is not yet stable in the sense of working. So probably the nightlies are not yet updated to them.
(3.1 uses a different build system)

Also java 6 long term support already ended, and java 7 is ending next month, consider to update?

It was only the JDK which was outdated, but I updated to java 8 now.

I am trying to compile jme3.1 right now (actually I only need jme3-blender, but it depends on jme-core…)

The Problem now is Issue 221 (Gradle 2.3).
I hope gradlew is only localling installing and not overwriting my 2.3 in /usr/share

Edit: Got it now :slight_smile: I am so excited and hope I can simply enter the plugin into netbeans without using the new sdk

Edit 2: Does anyone know how to compile the three jar’s to a nbm?
Problem is, the 3.1 sdk loader refuses to do anything :frowning:

If you open the SDK project in netbeans, you can right click on it and “package as/Zip distribution” among other choices

1 Like

Yeah, my 3.1 is up and running :smile:
The only problem now is, that the BlenderImporter refuses to load any blend file :confused:

This file can not be loaded, it is either in an unsupported format or is incompatible.
Check the bottom right corner of the SDK for a little warning sign. If it is there double-click it and report the contained stack trace at

I don’t have any stack trace or anything at all.

Anything in the application log? Also, what version of blender are you using?

DesktopAssetManager created.
Add locator: /Users/darki/Documents/jmonkey/Models/MakeHuman_Humans/Paige
Clearing asset List
Clearing asset List
Start offview panel
Camera created (W: 320, H: 320)
Loading noise constants.
Root Node (Node): All children removed.
Stop offview panel
Component hidden
Root Node (Node): All children removed.

So basically nothing. And the blender version is 2.69 (bundled with jme 3.0), but it used to work with said 3.0 sdk.
I can try a newer version, though.

btw: not even the shell which is spawned on launch contains anything

Theres been some changes in the blender loader lately, a different loader class is used and whatnot, I’d not expect the git version to work with the 3.0 SDK actually.

That’s why I used the new 3.1 sdk, a complete git build.

In master the SDK hasn’t been adapted to the blender loader changes either, neither have the changes been tested at all.

hum, can I call the loader manually using the assetManager?
Kaelthas did some changes I urgently would need for MakeHumans Animations to work and he had it working, somehow.