Plugin Updates for jMonkeyEngine 3.0

Hi All,

I have just installed the sdk and when I start it up it says there are 22 plugin updates. So I start off the update process but it never gets past 5%, just hangs there until it times out.

My network is fine in regards to bandwidth. I had no firewalls on just to be sure. I even changed from my isp set dns to google public dns on my router just in case…!Had dns issues with my isp before.

Is this a known issue does anyone know? :slight_smile:

Any ideas would be greatly appreciated

What are the repositories you are updating from. Try just the Unstable one. And make sure your jMP haven’t any proxy set.

Thanks for the reply. I am looking at the plugins section under the tools menu. If I look at the Settings tab I dont have an Unstable option showing. Just the nightly, stable and user contributions and android. Am I doing it wrong? Soz to be a pain :slight_smile:

Have you unset the proxy in jMP like I said? Also, make sure you’ve downloaded the jMP Beta version, and not the Alpha one xD. And, what are the updates?

Yeah have it set it to proxy. The file I downloaded was this one jME3_SDK_Beta-windows.exe

The updates are for plugins.The window they are in is named Plugin installer and lists many…android support, applet support, desktop deployment support…sdk core etc etc

Its weird because when I was at work ealrier I had the same problem and our internet connection there goes over a leased line to belgium where our head office is then out through their belgium isp… yet I live in London and am at home with the same issue now. Confusing lol

Hmm. The nightly settings should be set automatically. As it isn’t, then set it manually. Here are my settings:

Yeah that’s wierd. Tried changing it but get the same issue, still seems to hang on 5% of downloading the sdk core update for about a minute then errors saying connection reset. I’ll try completely uninstalling and start over. Thanks for your help so far.

Yeah have it set it to proxy

Do you mean like so?

Ah yes, sorry It was set as your screenshot. ‘No proxy’. Well tried reinstall but no luck…I’ll try tomo maybe it’s my isp, have had weird issues in past like this with Orange.

Just tried again and here is the result. (it says 100% downloaded but it had hung at 5% for a minute then shot to 100% and popped up the error.

When this happens I simply do a reload catalog. Sometimes I restart the SDK and / or the internet connection to make it works.

Yeah done that a few times but will keep trying. Weirdly I get this same problem wiht one other piece of software, Minecraft, but nothing else. Anyway. I’ll keep trying tomo. Thanks for all your help :slight_smile:

is there somewhere they can be manually downlaoded?

I’ve already tried that, but it doesn’t work. There’s a link where you can download them as well, but when you try to install the .nbm files, it simply download, and doesn’t install. Are you connected from dns server? Do you use proxy for your browsers?

There’s nothing weird with your model. I was able to load it both in SceneComposer and in source code as well. Make sure your jMP is up to date. In source code I did so:


// rootNode.attachChild(assetManager.loadModel(“Models/dressoirNoir.obj”));

rootNode.addLight(new PointLight());

Both .obj and .j3o works like a boss. I’m using the lastest unstable nightly builds.

Ops, wrong topic xD.

When u say connected from dns server. At home its just me, my laptop and a lynksis router. At work yes there is a proxy so I can understand that causes issues. Definitely not using proxy at home. All my browsers set to not use a proxy.

What I am doing now is uninstalling the jmonkey sdk and all versions of java I have and trying it all again. I was getting a lot of java crashes after trying to update the sdk so maybe something was up with my java installs.

Hi again, Its working woooot!. I ended up wiping all copies of java from my system and uninstalled jmonkey sdk. Rebooted. Made sure no directories were left over from uninstalls.

Downloaded jre 6u30 and jdk 6u30…installed them. Reinstalled jmonkey and ran update… All was well. So I guess it must have been a java issue.

I am sooo happy, that’s my weekend sorted now. Thanks again for all the help.